summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-14 08:05:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-14 08:05:54 +0100
commite6d0fc2ac5e6707fbd01633e7025441e8e6b5cb9 (patch)
treedec36145f5cab3b54684aeb3968a10dcf0dd361f /dev-python/nbformat
parentdev-python/boto3: Bump to 1.16.54 (diff)
downloadgentoo-e6d0fc2ac5e6707fbd01633e7025441e8e6b5cb9.tar.gz
gentoo-e6d0fc2ac5e6707fbd01633e7025441e8e6b5cb9.tar.bz2
gentoo-e6d0fc2ac5e6707fbd01633e7025441e8e6b5cb9.zip
dev-python/nbformat: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 7f7ff795583f..3108190e1d36 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1 +1,2 @@
DIST nbformat-5.0.8.gh.tar.gz 127329 BLAKE2B 6252d35f72fd0af5a89d83e9e48f61baf2656eb6530d4a7b05a5241e7272098992d70d68705da4fb9921ab1939378658b2e6e5f765a453f932e94e9232006a66 SHA512 956add98517f1128d8efacae1f3cf9fe27b4d7acae4a56e14dd6c2942aab39b063170759bc6de67bcedd2e0fd6c7ab1a36aef268f2088644ba31caa936b9359d
+DIST nbformat-5.1.0.gh.tar.gz 152052 BLAKE2B 571d48af8c92b1cff9110935e00f53543d7bbae5ed9a08b516e9ff23366d9db7e4b1fb50dc786f2cd70d7f871baa05b6be86a6f22940724d90d05fdf58449bba SHA512 17c234e7777c170d629c0d3a4d8d7ddf01a754977a5e21357550ff702c5b4e26cd31164b32ced0fb20f3c0953390efd9a7509ed92f6c159fcef8634bd3f6af53
diff --git a/dev-python/nbformat/nbformat-5.1.0.ebuild b/dev-python/nbformat/nbformat-5.1.0.ebuild
new file mode 100644
index 000000000000..6991991c0a60
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+# missing on pypi
+SRC_URI="
+ https://github.com/jupyter/nbformat/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ test? (
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest