summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-04 08:57:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-04 10:06:17 +0200
commita8b60ab3dcfd59ffb4ff580b367af13e60df201f (patch)
tree5e97da713c75814819a4a8dd7d36769cb4869477 /dev-python/nbclassic
parentdev-python/dulwich: Bump to 0.21.5 (diff)
downloadgentoo-a8b60ab3dcfd59ffb4ff580b367af13e60df201f.tar.gz
gentoo-a8b60ab3dcfd59ffb4ff580b367af13e60df201f.tar.bz2
gentoo-a8b60ab3dcfd59ffb4ff580b367af13e60df201f.zip
dev-python/nbclassic: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest1
-rw-r--r--dev-python/nbclassic/nbclassic-1.0.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index a8514687f183..c40878f808ed 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1,2 +1,3 @@
DIST nbclassic-0.5.5.tar.gz 20200594 BLAKE2B 43de88221af5461e2814f7d8963d7f9f675463f116092d1fb40648a8a14065aa5888ad207b1d845884f9b5b6d6a65a8f6197e94661b7a255c84d5b34ea0c5c99 SHA512 54e22ee41a2cb497c3792b74213c13dfbcef7a8a6fb42e48a06aa6969987cec39bf0cfa835e24062e8181bd732cf6b6855f9e834a586b15c584b47df06455b34
DIST nbclassic-0.5.6.tar.gz 20201214 BLAKE2B 07643a35e0167af860ce382212685b988e8ec979cfe6e3436998e467f36a1f4381343c7e2513bc3a08d3cd384d6e6369cae20f77c9b0636559ce8f66b4ee2f63 SHA512 e259edb862a870c2b992c6c2c2d8ead64fc69f98298bd1830d63f1db001f8b36ab9509a693b5e425dcc2a43eb72b256f1082b1f0c66757bdbf35968175eb58c7
+DIST nbclassic-1.0.0.tar.gz 20201455 BLAKE2B 8d87668cdf2347c6d9dcc7f335d9bf346c1622217b71c18a91f7703f90ab5d2c71830f9743d6b408033ab153fe7180a9f07edc016704b9d0469bbf15c1641ef8 SHA512 fc80cd6311ab9cac9e0fdcf4d37cffc383c90327da8c27901239b84486e4afe23372665b0e1464ec78845816e829c4f3cf8672b4a0ad7e396fdb962b2f4f5a1b
diff --git a/dev-python/nbclassic/nbclassic-1.0.0.ebuild b/dev-python/nbclassic/nbclassic-1.0.0.ebuild
new file mode 100644
index 000000000000..dbd9a062a219
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-1.0.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbclassic/
+ https://pypi.org/project/nbclassic/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.6.1[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-5[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2.3[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+"
+
+# dev-python/nbval is missing impls
+BDEPEND="
+ test? (
+ dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ doc? (
+ virtual/pandoc
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme \
+ dev-python/nbsphinx \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/myst-parser \
+ dev-python/ipython_genutils
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}