summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 09:21:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 09:27:48 +0200
commitf2247b336beb039806ccf884bd6c86cf5cff87be (patch)
tree0c24fa93d4818c83b985c72ad3313af98e3c232b /dev-python/mypy_extensions
parentdev-python/dominate: Remove old (diff)
downloadgentoo-f2247b336beb039806ccf884bd6c86cf5cff87be.tar.gz
gentoo-f2247b336beb039806ccf884bd6c86cf5cff87be.tar.bz2
gentoo-f2247b336beb039806ccf884bd6c86cf5cff87be.zip
dev-python/mypy_extensions: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mypy_extensions')
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.3.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.3.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.3.ebuild
deleted file mode 100644
index 0536aa7c3de8..000000000000
--- a/dev-python/mypy_extensions/mypy_extensions-0.4.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
-
-inherit distutils-r1
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="http://www.mypy-lang.org/"
-SRC_URI="https://github.com/python/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-if [ "${PV}" == "9999" ]; then
-inherit git-r3
-EGIT_REPO_URI="https://github.com/python/${PN}"
-EGIT_COMMIT="master"
-else
-EGIT_REPO_URI="${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- test? ( dev-python/flake8[${PYTHON_USEDEP}] )
- ${RDEPEND}
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover tests -v || die "tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}