summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-06-05 14:59:18 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-06-05 15:01:17 -0500
commitc89c6ed3879a9d6c137caabce339dc5b62c4edcf (patch)
treef4c964d45d8402db3e0c9b20b12095deba7d054a /dev-python/mypy
parentdev-python/PyQt5: x86 stable (diff)
downloadgentoo-c89c6ed3879a9d6c137caabce339dc5b62c4edcf.tar.gz
gentoo-c89c6ed3879a9d6c137caabce339dc5b62c4edcf.tar.bz2
gentoo-c89c6ed3879a9d6c137caabce339dc5b62c4edcf.zip
dev-python/mypy: fix #584556
Apparently, I misread the dependencees and added the dependence on typing that should have been a blocker. This commit rectifies that situation. I'm not convinced other problems don't exist and we may see more bugs before this is completely resolved. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/mypy-0.4.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/mypy/mypy-0.4.1.ebuild b/dev-python/mypy/mypy-0.4.1.ebuild
index 38f9f5e4ca31..5d7d96ce3b31 100644
--- a/dev-python/mypy/mypy-0.4.1.ebuild
+++ b/dev-python/mypy/mypy-0.4.1.ebuild
@@ -23,7 +23,7 @@ DEPEND="
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
"
-RDEPEND="$(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"
+RDEPEND="$(python_gen_cond_dep '!dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"
python_compile_all() {
use doc && emake -C docs html