summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/mypy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/files/use-which.patch20
-rw-r--r--dev-python/mypy/metadata.xml13
-rw-r--r--dev-python/mypy/mypy-0.2.0-r1.ebuild48
-rw-r--r--dev-python/mypy/mypy-0.2.0.ebuild40
5 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
new file mode 100644
index 000000000000..7a82e9c33420
--- /dev/null
+++ b/dev-python/mypy/Manifest
@@ -0,0 +1 @@
+DIST mypy-0.2.0.tar.gz 626604 SHA256 0c24f50509bdf3e0d9bd386a08ef4f11ee0114e1f5a9b2afeacbf9561cf022c1 SHA512 b03014abf152407c7629dba925aca6178fcdf57532f47c728edcb591a56942cda13e02122f405aa269e9b6303de1f4a9d5cbb2d5a5af6e90a808a3db94cca53f WHIRLPOOL 7d9f05ead0bfea78bdf228b0bb7c3519e8eaa70f52c00049963780f42e71e9f44168edb09d2e558f59b07a4d09912d1d6d3c8b11a2b9e47db77b2c06e56eb910
diff --git a/dev-python/mypy/files/use-which.patch b/dev-python/mypy/files/use-which.patch
new file mode 100644
index 000000000000..bca26f03c76e
--- /dev/null
+++ b/dev-python/mypy/files/use-which.patch
@@ -0,0 +1,20 @@
+diff --git a/scripts/mypy b/scripts/mypy
+index e758f1f..5a06146 100755
+--- a/scripts/mypy
++++ b/scripts/mypy
+@@ -45,14 +45,7 @@ def find_bin_directory() -> str:
+
+ This is used by build to find stubs and other data files.
+ """
+- script = __file__
+- # Follow up to 5 symbolic links (cap to avoid cycles).
+- for i in range(5):
+- if os.path.islink(script):
+- script = readlinkabs(script)
+- else:
+- break
+- return os.path.dirname(script)
++ return os.path.dirname(shutil.which('mypy'))
+
+
+ def readlinkabs(link: str) -> str:
diff --git a/dev-python/mypy/metadata.xml b/dev-python/mypy/metadata.xml
new file mode 100644
index 000000000000..082e0c25fc4a
--- /dev/null
+++ b/dev-python/mypy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">JukkaL/mypy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mypy/mypy-0.2.0-r1.ebuild b/dev-python/mypy/mypy-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..0b30dccda29e
--- /dev/null
+++ b/dev-python/mypy/mypy-0.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/use-which.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( samples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/mypy/mypy-0.2.0.ebuild b/dev-python/mypy/mypy-0.2.0.ebuild
new file mode 100644
index 000000000000..7d8aef31dfda
--- /dev/null
+++ b/dev-python/mypy/mypy-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( samples/. )
+
+ distutils-r1_python_install_all
+}