summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-23 10:22:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-23 10:22:46 +0100
commit8060e4bc3a815ea334040e0c6c991b865779d052 (patch)
treec6d515c8b06687a32a1a31a9d7c178f34dc34f15 /dev-python/multidict
parentdev-python/pulsectl: Bump to 22.1.3 (diff)
downloadgentoo-8060e4bc3a815ea334040e0c6c991b865779d052.tar.gz
gentoo-8060e4bc3a815ea334040e0c6c991b865779d052.tar.bz2
gentoo-8060e4bc3a815ea334040e0c6c991b865779d052.zip
dev-python/multidict: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/multidict')
-rw-r--r--dev-python/multidict/Manifest1
-rw-r--r--dev-python/multidict/multidict-6.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index ab5507fc0bd0..41f8f5cafdee 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1 +1,2 @@
DIST multidict-5.2.0.tar.gz 56984 BLAKE2B 3580e3f53b3ec581d338676647f2e8dd78387fdad5730fe703c02b3cd4182d69e3b6896d71bd969413dd27974e07272cc541701a2145a517d9bacea45000e9c8 SHA512 508b6db9219c3dae76da5e89a398f4541beff2a875030c2f11da9aaa1e001324d069d7a291148c510fe555cb3a33288ef297c9baa863e42d3d09d60588bebd7e
+DIST multidict-6.0.0.tar.gz 56006 BLAKE2B 886e7e02da1eb80ca2a7106dd127d0164155fa400125f4fa0c880d508407ad1b436e52d77f331843f908d5ab5497aac002d72445615666b0621a8e436397598f SHA512 9f258795166fd3c6f56286fd98da8cf7ce9bc5d7a974174865164f0955c71263234307733c0edcc5d0142c1356d681e24c93c3be6f5dbee67f01dee6a39b32d2
diff --git a/dev-python/multidict/multidict-6.0.0.ebuild b/dev-python/multidict/multidict-6.0.0.ebuild
new file mode 100644
index 000000000000..f45187aed2ff
--- /dev/null
+++ b/dev-python/multidict/multidict-6.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND=">=dev-python/cython-0.28.4[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't enable coverage or other pytest settings
+ sed -i -e 's:--cov.*::' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}