summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 14:08:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 15:11:04 +0200
commit777ac660dbcdcc6f4bd9226767ac3eac9094e7af (patch)
treece0043e2271fa22a9bc64328e5469b3a85a89930 /dev-python/mpi4py
parentdev-python/passlib: Clean old versions up (diff)
downloadgentoo-777ac660dbcdcc6f4bd9226767ac3eac9094e7af.tar.gz
gentoo-777ac660dbcdcc6f4bd9226767ac3eac9094e7af.tar.bz2
gentoo-777ac660dbcdcc6f4bd9226767ac3eac9094e7af.zip
dev-python/mpi4py: Clean old versions up
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/Manifest1
-rw-r--r--dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch24
-rw-r--r--dev-python/mpi4py/files/mpi4py-1.3.1-py3-test-backport-1.patch81
-rw-r--r--dev-python/mpi4py/mpi4py-1.3.1.ebuild49
4 files changed, 0 insertions, 155 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
index 2031eec7cd02..04a772372e86 100644
--- a/dev-python/mpi4py/Manifest
+++ b/dev-python/mpi4py/Manifest
@@ -1,2 +1 @@
-DIST mpi4py-1.3.1.tar.gz 1046580 SHA256 e7bd2044aaac5a6ea87a87b2ecc73b310bb6efe5026031e33067ea3c2efc3507 SHA512 15e81f2a1e6f6af7a54f0e8ec43ddf36cc565b7fe9e3dd35603c9d128199c5acd1584757ffca999c8826c0bbccf371175d40a7a24c85d3369efd77da5b3b603f WHIRLPOOL e32fef50c8cd8f866e40fb29f90775736cf0ea31c8a3fc4d460cded8b2056bae0c8d847b304c3222d3e5ffc913ca5cc722425e496d35bf41624f9b5ccdf3ead2
DIST mpi4py-2.0.0.tar.gz 1279957 SHA256 6543a05851a7aa1e6d165e673d422ba24e45c41e4221f0993fe1e5924a00cb81 SHA512 6459b482db782fea1a80499774ebfeb09c828b6c3f1805a0ca306f26f3ebcac52ad1c83bb97a98a01b518b6a6c887f6b99dbda9c37381a5ce05ddff0edb16d81 WHIRLPOOL 1b85699303a813cc35118464c80dffe798eb02dd3248c0b61937236f2f6cea533283a443f8a52298d888584e13e013601260b68552528d1b9b6f25bcccb990e7
diff --git a/dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch b/dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch
deleted file mode 100644
index ae1eade0de2d..000000000000
--- a/dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-# HG changeset patch
-# User Christoph Junghans <junghans@votca.org>
-# Date 1407773183 21600
-# Mon Aug 11 10:06:23 2014 -0600
-# Node ID ee313041ba5d7f0706f8140b4e965179e807ef56
-# Parent c66c1be9d40ae69aa61c45572fbe14ef3209378e
-Fix usage of LDSHARED
-
-- LDSHARED contain the linker, too
-- was used as it would only contain the options in the latter part
-- use split_linker_cmd to throw away the linker cmd
-- see https://bugs.gentoo.org/show_bug.cgi?id=514288
-
-diff -r c66c1be9d40a -r ee313041ba5d conf/mpidistutils.py
---- a/conf/mpidistutils.py Wed Sep 04 22:40:25 2013 +0300
-+++ b/conf/mpidistutils.py Mon Aug 11 10:06:23 2014 -0600
-@@ -176,6 +176,7 @@
- opt = environ.get('OPT', opt )
- ccshared = environ.get('CCSHARED', ccshared)
- ldshared = environ.get('LDSHARED', ldshared)
-+ _, ldshared = split_linker_cmd(ldshared)
- cflags = ' '.join((basecflags, opt, cflags))
- cxxflags = ' '.join((basecflags, opt, cxxflags))
- cxxflags = cxxflags.replace('-Wstrict-prototypes', '')
diff --git a/dev-python/mpi4py/files/mpi4py-1.3.1-py3-test-backport-1.patch b/dev-python/mpi4py/files/mpi4py-1.3.1-py3-test-backport-1.patch
deleted file mode 100644
index f92639f5be5f..000000000000
--- a/dev-python/mpi4py/files/mpi4py-1.3.1-py3-test-backport-1.patch
+++ /dev/null
@@ -1,81 +0,0 @@
- test/test_win.py | 48 +++++++++++++++++++++++++++++++++++++-----------
- 1 file changed, 37 insertions(+), 11 deletions(-)
-
-diff --git a/test/test_win.py b/test/test_win.py
-index 6da5c1f..7127e56 100644
---- a/test/test_win.py
-+++ b/test/test_win.py
-@@ -1,6 +1,30 @@
- import sys
- from mpi4py import MPI
- import mpiunittest as unittest
-+try:
-+ from sys import getrefcount
-+except ImportError:
-+ class getrefcount(object):
-+ def __init__(self, arg):
-+ pass
-+ def __eq__(self, other):
-+ return True
-+ def __add__(self, other):
-+ return self
-+ def __sub__(self, other):
-+ return self
-+
-+def memzero(m):
-+ n = len(m)
-+ if n == 0: return
-+ try:
-+ zero = '\0'.encode('ascii')
-+ m[0] = zero
-+ except TypeError:
-+ zero = 0
-+ m[0] = zero
-+ for i in range(n):
-+ m[i] = zero
-
- class BaseTestWin(object):
-
-@@ -11,29 +35,31 @@ class BaseTestWin(object):
- try:
- self.mpi_memory = MPI.Alloc_mem(10)
- self.memory = self.mpi_memory
-- try:
-- zero = bytearray([0])
-- except NameError:
-- zero = str('\0')
-- self.memory[:] = zero * len(self.memory)
-+ memzero(self.memory)
- except MPI.Exception:
- from array import array
- self.mpi_memory = None
- self.memory = array('B',[0]*10)
-- refcnt = sys.getrefcount(self.memory)
-+ refcnt = getrefcount(self.memory)
- self.WIN = MPI.Win.Create(self.memory, 1, self.INFO, self.COMM)
- if type(self.memory).__name__ == 'buffer':
-- self.assertEqual(sys.getrefcount(self.memory), refcnt+1)
-+ self.assertEqual(getrefcount(self.memory), refcnt+1)
- else:
-- self.assertEqual(sys.getrefcount(self.memory), refcnt)
-+ if sys.version_info[:3] < (3, 3):
-+ self.assertEqual(getrefcount(self.memory), refcnt)
-+ else:
-+ self.assertEqual(getrefcount(self.memory), refcnt+1)
-
- def tearDown(self):
-- refcnt = sys.getrefcount(self.memory)
-+ refcnt = getrefcount(self.memory)
- self.WIN.Free()
- if type(self.memory).__name__ == 'buffer':
-- self.assertEqual(sys.getrefcount(self.memory), refcnt-1)
-+ self.assertEqual(getrefcount(self.memory), refcnt-1)
- else:
-- self.assertEqual(sys.getrefcount(self.memory), refcnt)
-+ if sys.version_info[:3] < (3, 3):
-+ self.assertEqual(getrefcount(self.memory), refcnt)
-+ else:
-+ self.assertEqual(getrefcount(self.memory), refcnt-1)
- if self.mpi_memory:
- MPI.Free_mem(self.mpi_memory)
-
diff --git a/dev-python/mpi4py/mpi4py-1.3.1.ebuild b/dev-python/mpi4py/mpi4py-1.3.1.ebuild
deleted file mode 100644
index 60c2b58341dd..000000000000
--- a/dev-python/mpi4py/mpi4py-1.3.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.python.org/pypi/mpi4py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="virtual/mpi"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- virtual/mpi[romio] )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}"/${P}-py3-test-backport-1.patch "${FILESDIR}"/${P}-ldshared.patch )
-
-python_prepare_all() {
- # not needed on install
- rm -r docs/source || die
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- export FAKEROOTKEY=1
- distutils-r1_src_compile
-}
-
-python_test() {
- echo "Beginning test phase"
- pushd "${BUILD_DIR}"/../ &> /dev/null
- mpiexec -n 2 "${PYTHON}" ./test/runtests.py -v || die "Testsuite failed under ${EPYTHON}"
- popd &> /dev/null
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}