summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/moto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest3
-rw-r--r--dev-python/moto/metadata.xml13
-rw-r--r--dev-python/moto/moto-0.3.8.ebuild26
-rw-r--r--dev-python/moto/moto-0.4.3.ebuild27
-rw-r--r--dev-python/moto/moto-0.4.8.ebuild27
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
new file mode 100644
index 000000000000..2769d63271fc
--- /dev/null
+++ b/dev-python/moto/Manifest
@@ -0,0 +1,3 @@
+DIST moto-0.3.8.tar.gz 101161 SHA256 0215034a2834d86ff622c11bcba2570240a54635cda5ec83d48c1e663179b047 SHA512 f414499b6c475b3a5e69570997b0f96fc9d998f622209d48b686c1f77a33e984e95028806ae1ba1ec1d41d75e59b83f96bd66b566c8a7b664dacc910c0035edd WHIRLPOOL 13e5edd809a772c9ce955196ca268db4663c8d68959a4fa7fcaaa44ebf0f6d147d471bf00d27a6ec2d0a4e4a1a037fb09756ad92d0733601f852f522f2ce265e
+DIST moto-0.4.3.tar.gz 147498 SHA256 955b0a19d466c917b5c9e97a03df6f10d184dea263efdd7796b1725b4a90a48c SHA512 3c8a2b5cf2b404f531d187adb96f03d38ec89ce147066922f8da7e71e33b2cbe01b5264d1dd7f7abddc9a94759e4ee6b3111da3838796acbd1a83ad6fbfd4a21 WHIRLPOOL 8cf88239a4c1acbfce293133e68baa05783800754a1f07c33a3643f071bcb0a0e68f7215b8696a378de71369edfead00a1708ba0b276108e0bb446f981343943
+DIST moto-0.4.8.tar.gz 154891 SHA256 d72a0427a0112a21f7009e2301ed7cc7c9fb085da1e1615fba4c5f02f6d70bd1 SHA512 e52a8fefd22983996718eec49e607a26978604e67a50523ee43fbf8c1d0ce871cc390404c7ae6951d6bff9b640f3b4dffa3a3d4425134a056e37db2ebcdcaacf WHIRLPOOL 4e0e1fb89571e53cfb1a67b6627b852b37743539917912e56bf9c596bd86981c3c2115cb7ca8b1014767db55a19363ce2604bb860aace1214eb597eea6722852
diff --git a/dev-python/moto/metadata.xml b/dev-python/moto/metadata.xml
new file mode 100644
index 000000000000..bf151f0343d0
--- /dev/null
+++ b/dev-python/moto/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">moto</remote-id>
+ <remote-id type="github">spulec/moto</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/moto/moto-0.3.8.ebuild b/dev-python/moto/moto-0.3.8.ebuild
new file mode 100644
index 000000000000..e68c33e95253
--- /dev/null
+++ b/dev-python/moto/moto-0.3.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"
diff --git a/dev-python/moto/moto-0.4.3.ebuild b/dev-python/moto/moto-0.4.3.ebuild
new file mode 100644
index 000000000000..dcb9d700aa35
--- /dev/null
+++ b/dev-python/moto/moto-0.4.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.20.0[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.6.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"
diff --git a/dev-python/moto/moto-0.4.8.ebuild b/dev-python/moto/moto-0.4.8.ebuild
new file mode 100644
index 000000000000..dcb9d700aa35
--- /dev/null
+++ b/dev-python/moto/moto-0.4.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.20.0[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.6.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"