summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-30 04:06:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-30 04:09:17 +0100
commitc81c6f1abb046f12801e0f753669ffc849824575 (patch)
tree159fddde53a9b175ff875898a2299c7e273592fb /dev-python/meson-python
parentdev-python/wsaccel: Remove old (diff)
downloadgentoo-c81c6f1abb046f12801e0f753669ffc849824575.tar.gz
gentoo-c81c6f1abb046f12801e0f753669ffc849824575.tar.bz2
gentoo-c81c6f1abb046f12801e0f753669ffc849824575.zip
dev-python/meson-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/files/meson-python-0.7.0-defaults.patch14
-rw-r--r--dev-python/meson-python/meson-python-0.10.0-r1.ebuild53
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 1a826662967f..6bcfab8c89b7 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,2 +1 @@
-DIST meson-python-0.10.0.gh.tar.gz 37739 BLAKE2B 028cbb191076b49946576b02d26a84079f412a178d9829bf85d579b8d3624e192e9394ade31524faf972ef4d105b7bf703e750529a7fafcbadf9a52d3c4876c6 SHA512 50d4d0bbf810948b4f218f25815058778b2a3ac8ff811d4d7cc699d1cfbcb75612d28789080b4e5ec3a47be03636389b7bf313366273abb733f77644758747cb
DIST meson-python-0.11.0.gh.tar.gz 43192 BLAKE2B c12a18698f270b36685bbd4ad7ff5f2a718bab28f834cad89be724457704cd56966247e13ed6ba7dd201c5397ccfc78ab9202e7435f0672d63d544f67323b7b3 SHA512 fb894d0db6d18febd6388b7e686d0c7c1e3308f6ebf926c7300e2f376b1d2a803adcf5925c80d05982805e3ce4a59676c9ef829eacdab4696dabec3cb93e4192
diff --git a/dev-python/meson-python/files/meson-python-0.7.0-defaults.patch b/dev-python/meson-python/files/meson-python-0.7.0-defaults.patch
deleted file mode 100644
index 8a9b4fc21d5a..000000000000
--- a/dev-python/meson-python/files/meson-python-0.7.0-defaults.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-See https://github.com/FFY00/meson-python/blob/main/mesonpy/__init__.py#L452.
-
-(Also: https://github.com/FFY00/meson-python/issues/54)
---- a/mesonpy/__init__.py
-+++ b/mesonpy/__init__.py
-@@ -532,7 +532,7 @@ class Project():
- @functools.lru_cache(maxsize=None)
- def build(self) -> None:
- """Trigger the Meson build."""
-- self._meson('compile')
-+ self._meson('compile', '--verbose')
- self._meson('install', '--destdir', os.fspath(self._install_dir))
-
- @classmethod
diff --git a/dev-python/meson-python/meson-python-0.10.0-r1.ebuild b/dev-python/meson-python/meson-python-0.10.0-r1.ebuild
deleted file mode 100644
index 9ea40c9a74b3..000000000000
--- a/dev-python/meson-python/meson-python-0.10.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Meson PEP 517 Python build backend"
-HOMEPAGE="
- https://pypi.org/project/meson-python/
- https://github.com/mesonbuild/meson-python/
-"
-SRC_URI="
- https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
- dev-util/patchelf
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.0-defaults.patch
-)
-
-distutils_enable_sphinx docs \
- dev-python/furo \
- dev-python/sphinx-autodoc-typehints
-distutils_enable_tests pytest
-
-src_prepare() {
- # strip dependency on ninja -- we provide ninja via Gentoo package
- # rather than the Python wheel, so we don't have .dist-info there
- sed -i -e '/ninja/d' pyproject.toml || die
- distutils-r1_src_prepare
-}