summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-21 22:07:56 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-21 22:07:56 +0200
commit4c88076048889b71a8202b4604491b0dde62fe38 (patch)
tree5ffa556b8021895a0b58c4a8bb1b870ea74fea38 /dev-python/meson-python
parentdev-python/cairocffi: Keyword 1.4.0 hppa, #872830 (diff)
downloadgentoo-4c88076048889b71a8202b4604491b0dde62fe38.tar.gz
gentoo-4c88076048889b71a8202b4604491b0dde62fe38.tar.bz2
gentoo-4c88076048889b71a8202b4604491b0dde62fe38.zip
dev-python/meson-python: add 0.11.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/files/meson-python-0.11.0-defaults.patch14
-rw-r--r--dev-python/meson-python/meson-python-0.11.0.ebuild69
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index c7498c521693..1a826662967f 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1 +1,2 @@
DIST meson-python-0.10.0.gh.tar.gz 37739 BLAKE2B 028cbb191076b49946576b02d26a84079f412a178d9829bf85d579b8d3624e192e9394ade31524faf972ef4d105b7bf703e750529a7fafcbadf9a52d3c4876c6 SHA512 50d4d0bbf810948b4f218f25815058778b2a3ac8ff811d4d7cc699d1cfbcb75612d28789080b4e5ec3a47be03636389b7bf313366273abb733f77644758747cb
+DIST meson-python-0.11.0.gh.tar.gz 43192 BLAKE2B c12a18698f270b36685bbd4ad7ff5f2a718bab28f834cad89be724457704cd56966247e13ed6ba7dd201c5397ccfc78ab9202e7435f0672d63d544f67323b7b3 SHA512 fb894d0db6d18febd6388b7e686d0c7c1e3308f6ebf926c7300e2f376b1d2a803adcf5925c80d05982805e3ce4a59676c9ef829eacdab4696dabec3cb93e4192
diff --git a/dev-python/meson-python/files/meson-python-0.11.0-defaults.patch b/dev-python/meson-python/files/meson-python-0.11.0-defaults.patch
new file mode 100644
index 000000000000..6bd63f6d132e
--- /dev/null
+++ b/dev-python/meson-python/files/meson-python-0.11.0-defaults.patch
@@ -0,0 +1,14 @@
+See https://github.com/mesonbuild/meson-python/blob/main/mesonpy/__init__.py#L452.
+
+(Also: https://github.com/mesonbuild/meson-python/issues/54)
+--- a/mesonpy/__init__.py
++++ b/mesonpy/__init__.py
+@@ -734,7 +734,7 @@ class Project():
+ @functools.lru_cache(maxsize=None)
+ def build(self) -> None:
+ """Trigger the Meson build."""
+- self._meson('compile', *self._meson_args['compile'],)
++ self._meson('compile', '--verbose', *self._meson_args['compile'],)
+ self._meson('install', '--destdir', os.fspath(self._install_dir), *self._meson_args['install'],)
+
+ @classmethod
diff --git a/dev-python/meson-python/meson-python-0.11.0.ebuild b/dev-python/meson-python/meson-python-0.11.0.ebuild
new file mode 100644
index 000000000000..9bbfd957da01
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.11.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+)
+
+src_prepare() {
+ # strip dependency on ninja -- we provide ninja via Gentoo package
+ # rather than the Python wheel, so we don't have .dist-info there
+ sed -i -e '/ninja/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ )
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}