summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 19:37:49 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 20:32:37 +0200
commit73b7a79f113021b2bde60ba76931012f407ffb90 (patch)
tree474ff930028e07e0d3ed54e119503b891427b03f /dev-python/maybe
parentdev-python/pytest-runner: Bump (diff)
downloadgentoo-73b7a79f113021b2bde60ba76931012f407ffb90.tar.gz
gentoo-73b7a79f113021b2bde60ba76931012f407ffb90.tar.bz2
gentoo-73b7a79f113021b2bde60ba76931012f407ffb90.zip
dev-python/maybe: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/maybe')
-rw-r--r--dev-python/maybe/Manifest1
-rw-r--r--dev-python/maybe/maybe-0.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/maybe/Manifest b/dev-python/maybe/Manifest
index 2401d3c308dc..af883e2e9bd2 100644
--- a/dev-python/maybe/Manifest
+++ b/dev-python/maybe/Manifest
@@ -1 +1,2 @@
DIST maybe-0.3.0.tar.gz 5738 SHA256 214dc0bbf35e1174103711f068840b998f6f4fcd93d65957b9087906308fb45b SHA512 512b7b5251c27a64891bd105599b5625331cb21d40dbf7d1b88b56375a5ead484f02f87da6410c01682c180218cae7b0df7a9f92ad7a69a862b333ee36265152 WHIRLPOOL 4d6fdbc58b95a9e8ef9dd27404b17d70e84d38ee0e5f905de2dcee2cc33cfcedddca97fef2109141a42111688c0ff5a5ce407d81057b7d7d9c53fd83237a23df
+DIST maybe-0.4.0.tar.gz 6105 SHA256 581ad535104e8af27f56d1eecf92525c44d0440f228351fe195f56c0d45852b9 SHA512 39882c69375b408e809e899b997675c9395ddf50b8625fd04a0d78cbd041f6138e491b76578c8b530ba122b921c694bc27d256eab7485ea4638330f6e0411129 WHIRLPOOL 68d4ef05356c164ae5a764e3d922565e3a750c8a300b12ab3b87c18bc7636f08764a49a286fd315b3cffcf3cbe5dc6fd7c25c43e4ee8d68ad16d747f98ed6224
diff --git a/dev-python/maybe/maybe-0.4.0.ebuild b/dev-python/maybe/maybe-0.4.0.ebuild
new file mode 100644
index 000000000000..3db388f462d4
--- /dev/null
+++ b/dev-python/maybe/maybe-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="See what a program does before deciding whether you really want it to happen"
+HOMEPAGE="https://github.com/p-e-w/maybe http://pypi.python.org/pypi/maybe"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/blessings[${PYTHON_USEDEP}]
+ dev-python/python-ptrace[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/pytest-runner-2.7[${PYTHON_USEDEP}]
+"