summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 21:56:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 21:56:33 +0100
commit402c7317982455ce213ba02ebceff7340f1a6126 (patch)
tree26f66c91536b42bc5b57c8aeedba13cb6a406ef7 /dev-python/loguru
parentdev-python/logbook: Remove redundant versions (diff)
downloadgentoo-402c7317982455ce213ba02ebceff7340f1a6126.tar.gz
gentoo-402c7317982455ce213ba02ebceff7340f1a6126.tar.bz2
gentoo-402c7317982455ce213ba02ebceff7340f1a6126.zip
dev-python/loguru: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/loguru')
-rw-r--r--dev-python/loguru/Manifest2
-rw-r--r--dev-python/loguru/loguru-0.3.2.ebuild47
-rw-r--r--dev-python/loguru/loguru-0.4.0.ebuild24
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
index 322ae29d7d8b..ddb06af9d3e5 100644
--- a/dev-python/loguru/Manifest
+++ b/dev-python/loguru/Manifest
@@ -1,3 +1 @@
-DIST loguru-0.3.2.tar.gz 378160 BLAKE2B 83301f5bb79d0edb20d211e8ee4d05b3b93a0a9f13f13b2ff103f1e9759f227b80e5571ccda48098a1e45658d99a54768fdf456ffef7a13d08375ce62ad876e1 SHA512 e78f5f43fbf4891ff9b9a21c1a29e4f02877f73a09b7b7df25076bffb25a094eef561c469b22cbb999979de4dbf81df2298681fa219dc684f15fe7c52ecb5359
-DIST loguru-0.4.0.tar.gz 401317 BLAKE2B 00418647a240875706059d9f677a8377c3d169b92add3519c68a89ad2609ff48a55d735793749ab92a706f33611ba6d1b88a0b2e067ec6e80eb7827245bcb116 SHA512 2829cb888585998de5d1cfca815dbca32baa2c4b6ec61d6f165750e6ffaf847c6317846d8626189162131b36a6f2510dcb66bc05e72be76fabda11002a89767f
DIST loguru-0.4.1.tar.gz 404393 BLAKE2B 2dec4a346db3652a35a758bb9ce98f29785f47a55a107c0f924005607001adbd6e873095b7212a86bfa66d5d8a24f058d775552c1fa044fabd9813c09f369f26 SHA512 5b7dbac11bbd5c7cb05fe380cf4a3337309614cac77ded3b1f5191c8865d16788cafa7e8da25817787a1ae94e1b6905afe54184d72df81fad08821cdb68c0a53
diff --git a/dev-python/loguru/loguru-0.3.2.ebuild b/dev-python/loguru/loguru-0.3.2.ebuild
deleted file mode 100644
index fe109d742627..000000000000
--- a/dev-python/loguru/loguru-0.3.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python logging made (stupidly) simple"
-HOMEPAGE="https://github.com/Delgan/loguru"
-SRC_URI="https://github.com/Delgan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]"
-
-DEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- >=dev-python/pytest-4.5.0[${PYTHON_USEDEP}]
- )
-"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/loguru/loguru-0.4.0.ebuild b/dev-python/loguru/loguru-0.4.0.ebuild
deleted file mode 100644
index aed8f0048adf..000000000000
--- a/dev-python/loguru/loguru-0.4.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python logging made (stupidly) simple"
-HOMEPAGE="https://github.com/Delgan/loguru"
-SRC_URI="https://github.com/Delgan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/aiocontextvars[${PYTHON_USEDEP}]' 'python3_6')
- >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
-"
-# filesystem buffering tests may fail
-# on tmpfs with 64k PAGESZ, but pass fine on ext4
-distutils_enable_tests pytest