summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-27 07:57:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-27 08:10:34 +0200
commit3e0779ef01cda614df7313fecbad343475b32746 (patch)
tree99b9383711994e8ad7ea3f4ea39ac24dbec5a8bd /dev-python/lockfile
parentdev-python/trimesh: Bump to 3.12.5 (diff)
downloadgentoo-3e0779ef01cda614df7313fecbad343475b32746.tar.gz
gentoo-3e0779ef01cda614df7313fecbad343475b32746.tar.bz2
gentoo-3e0779ef01cda614df7313fecbad343475b32746.zip
dev-python/lockfile: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lockfile')
-rw-r--r--dev-python/lockfile/files/lockfile-0.12.2-pytest.patch20
-rw-r--r--dev-python/lockfile/lockfile-0.12.2-r3.ebuild31
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/lockfile/files/lockfile-0.12.2-pytest.patch b/dev-python/lockfile/files/lockfile-0.12.2-pytest.patch
new file mode 100644
index 000000000000..47362a4de6a0
--- /dev/null
+++ b/dev-python/lockfile/files/lockfile-0.12.2-pytest.patch
@@ -0,0 +1,20 @@
+diff -dup -r lockfile-0.12.2/test/compliancetest.py lockfile-0.12.2.new/test/compliancetest.py
+--- lockfile-0.12.2/test/compliancetest.py 2015-11-25 19:29:13.000000000 +0100
++++ lockfile-0.12.2.new/test/compliancetest.py 2022-05-27 07:55:43.720523461 +0200
+@@ -6,15 +6,13 @@ import lockfile
+
+
+ class ComplianceTest(object):
+- def __init__(self):
+- self.saved_class = lockfile.LockFile
+-
+ def _testfile(self):
+ """Return platform-appropriate file. Helper for tests."""
+ import tempfile
+ return os.path.join(tempfile.gettempdir(), 'trash-%s' % os.getpid())
+
+ def setup(self):
++ self.saved_class = lockfile.LockFile
+ lockfile.LockFile = self.class_to_test
+
+ def teardown(self):
diff --git a/dev-python/lockfile/lockfile-0.12.2-r3.ebuild b/dev-python/lockfile/lockfile-0.12.2-r3.ebuild
new file mode 100644
index 000000000000..3eee1e70ca38
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.12.2-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="
+ https://launchpad.net/pylockfile/
+ https://pypi.org/project/lockfile/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ >dev-python/pbr-1.8[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source --no-autodoc