summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-09 10:49:07 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-09 16:59:57 +0100
commit86da5bf6eefa31ec3f3dd9d96ce8cef5ac28b2f8 (patch)
tree490e8022f7f09877c668acf14745f148f4a5511f /dev-python/lit
parentsys-devel/llvm-common: Bump to 6.0.0rc2 (diff)
downloadgentoo-86da5bf6eefa31ec3f3dd9d96ce8cef5ac28b2f8.tar.gz
gentoo-86da5bf6eefa31ec3f3dd9d96ce8cef5ac28b2f8.tar.bz2
gentoo-86da5bf6eefa31ec3f3dd9d96ce8cef5ac28b2f8.zip
dev-python/lit: Bump to 6.0.0rc2
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-6.0.0_rc2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
index c3ef3a1554df..18d112f6ba15 100644
--- a/dev-python/lit/Manifest
+++ b/dev-python/lit/Manifest
@@ -1,3 +1,4 @@
DIST llvm-3.9.0.src.tar.xz 18235716 BLAKE2B c348d36cb21e716e8656b97489a0b7223fe81599e36ebf6f88d6191b1dec9eafc2d5d5413657ef89473af193b660c4b13317bebe5ecd02ad6c761c0ffdbe7f40 SHA512 f18ae32531218ab156c3e56c11826be0fd05f0799c82eaf2e6a043b38e1277560b4d921987513b88b11d97ea2619feaf277eec72181dd2ae4f4108c2836bf7b2
DIST llvm-4.0.1.src.tar.xz 21065652 BLAKE2B 6327eed2d1feb108440f22d2581d1ff86c10a10c29793538d8d899c7e2dc83d3f7b147d3fd4bcce2bd2bf57c071b08c624aeafe40a3e7a3914506e7751727e6c SHA512 16adc39b34ddb628f81b171119a8e2a0e9138b25011e803ef0b688e2fbea116fc4953d3a1b61b90a98a75e33619f81566b7cb06a9a2ea4d04ac5e0eb303a2d1d
DIST llvm-5.0.1.src.tar.xz 23428720 BLAKE2B 3db4d33df21018d17eef0042c0d8d82a8412bd5daa99cfb5405a6ec83c5774178fa76b220e8731c2a9a64dabf898aa90fe29c685327bd63a4f078e8e94a9a77e SHA512 bee1d45fca15ce725b1f2b1339b13eb6f750a3a321cfd099075477ec25835a8ca55b5366172c4aad46592dfd8afe372349ecf264f581463d017f9cee2d63c1cb
+DIST llvm-6.0.0rc2.src.tar.xz 25288140 BLAKE2B 095f054ce2ccb1eee3def2b8c6cecc610c4392283062338aa20d2de33c951484a2dc6774db2727e19e879307cfc95dda2730185cde8e52f4f45851d8dd809b3e SHA512 3cb3521ba8d90bf2a90c49d753ab5e92f1e0ccfc86946f3767c06d0f276e2c4cf8ff2f984680835efbaa4dae1cd2d3a074468e547785e05a67ea55311b94a0e9
diff --git a/dev-python/lit/lit-6.0.0_rc2.ebuild b/dev-python/lit/lit-6.0.0_rc2.ebuild
new file mode 100644
index 000000000000..21a3b1818491
--- /dev/null
+++ b/dev-python/lit/lit-6.0.0_rc2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+MY_P=llvm-${PV/_/}.src
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="http://prereleases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${MY_P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/lit" || die
+}
+
+python_test() {
+ ./lit.py -vv tests || die
+}