summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-18 08:50:31 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-28 10:14:17 +0100
commit5313553d2d098fe302993f715f23f77998707d20 (patch)
tree9612b0abdade00e1f11d0e3f03c63d3844f2b262 /dev-python/lit
parentsys-devel/llvm-common: Utilize partial git checkouts (diff)
downloadgentoo-5313553d2d098fe302993f715f23f77998707d20.tar.gz
gentoo-5313553d2d098fe302993f715f23f77998707d20.tar.bz2
gentoo-5313553d2d098fe302993f715f23f77998707d20.zip
dev-python/lit: Utilize partial git checkout
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-5.0.9999.ebuild5
-rw-r--r--dev-python/lit/lit-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/lit/lit-5.0.9999.ebuild b/dev-python/lit/lit-5.0.9999.ebuild
index 61b9ce3ec021..6d9f12eb032a 100644
--- a/dev-python/lit/lit-5.0.9999.ebuild
+++ b/dev-python/lit/lit-5.0.9999.ebuild
@@ -29,6 +29,11 @@ DEPEND="
# TODO: move the manpage generation here (from sys-devel/llvm)
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/lit
+}
+
python_test() {
./lit.py -sv tests || die
}
diff --git a/dev-python/lit/lit-9999.ebuild b/dev-python/lit/lit-9999.ebuild
index 063e1421607b..d8c140474d8d 100644
--- a/dev-python/lit/lit-9999.ebuild
+++ b/dev-python/lit/lit-9999.ebuild
@@ -28,6 +28,11 @@ DEPEND="
# TODO: move the manpage generation here (from sys-devel/llvm)
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/lit
+}
+
python_test() {
./lit.py -vv tests || die
}