summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2017-09-20 18:10:44 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-09-23 21:40:13 +0200
commitb438d547336ff12837b65f8fef20c53a33a76442 (patch)
treea1c171b07e12bd4f65038305d31fa110172fa40a /dev-python/libasyncns-python
parentdev-embedded/gputils: stable 1.5.0 for ppc64, bug #629936 (diff)
downloadgentoo-b438d547336ff12837b65f8fef20c53a33a76442.tar.gz
gentoo-b438d547336ff12837b65f8fef20c53a33a76442.tar.bz2
gentoo-b438d547336ff12837b65f8fef20c53a33a76442.zip
dev-python/libasyncns-python: fix build with glibc-2.25.
Gentoo-Bug: https://bugs.gentoo.org/609388 Closes: https://github.com/gentoo/gentoo/pull/5739
Diffstat (limited to 'dev-python/libasyncns-python')
-rw-r--r--dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch14
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild2
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch b/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch
new file mode 100644
index 000000000000..6ec84aa732b9
--- /dev/null
+++ b/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch
@@ -0,0 +1,14 @@
+https://sourceware.org/git/?p=glibc.git;a=patch;h=4f157746e0c713965d9143b52fef606312087c48
+
+diff --git a/libasyncns-python-0.7.1/libasyncns.c b/libasyncns-python-0.7.1/libasyncns.c
+index 99a73de..5e3da0b 100644
+--- a/libasyncns-python-0.7.1/libasyncns.c
++++ b/libasyncns-python-0.7.1/libasyncns.c
+@@ -134,7 +134,6 @@ PyMODINIT_FUNC initlibasyncns(void)
+ ADDNSCONST(ns_t_mailb);
+ ADDNSCONST(ns_t_maila);
+ ADDNSCONST(ns_t_any);
+- ADDNSCONST(ns_t_zxfr);
+ ADDNSCONST(ns_t_max);
+
+ ADDNSCONST(ns_c_invalid);
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
index 1b8e56d00254..2c5ab37721e6 100644
--- a/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
@@ -18,6 +18,8 @@ IUSE=""
DEPEND=">=net-libs/libasyncns-0.4"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-0.7.1-glibc-2.25.patch" )
+
python_compile() {
if [[ ${EPYTHON} != python3* ]]; then
local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"