summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 20:22:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 20:29:20 +0200
commit4f2064047d7d537c6a8ee283bd60ff1eb4267825 (patch)
treee6fbb652ed404d512f010c8c8714d3bf84766050 /dev-python/latexcodec
parentapp-accessibility/mbrola: drop 3.0.1h-r6 (diff)
downloadgentoo-4f2064047d7d537c6a8ee283bd60ff1eb4267825.tar.gz
gentoo-4f2064047d7d537c6a8ee283bd60ff1eb4267825.tar.bz2
gentoo-4f2064047d7d537c6a8ee283bd60ff1eb4267825.zip
dev-python/latexcodec: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/latexcodec')
-rw-r--r--dev-python/latexcodec/latexcodec-2.0.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/latexcodec/latexcodec-2.0.1-r1.ebuild b/dev-python/latexcodec/latexcodec-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..6c44ed911a37
--- /dev/null
+++ b/dev-python/latexcodec/latexcodec-2.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lexer and codec to work with LaTeX code in Python"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/latexcodec/
+ https://pypi.org/project/latexcodec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest