summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-10 18:43:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-10 22:11:52 +0100
commit8bbc5ee65d1d4d7ca43e686f004c1a742333b67e (patch)
treef81017c3efcfed7b799ff423842f613d67d77009 /dev-python/lark
parentdev-python/apispec: Bump to 6.4.0 (diff)
downloadgentoo-8bbc5ee65d1d4d7ca43e686f004c1a742333b67e.tar.gz
gentoo-8bbc5ee65d1d4d7ca43e686f004c1a742333b67e.tar.bz2
gentoo-8bbc5ee65d1d4d7ca43e686f004c1a742333b67e.zip
dev-python/lark: Bump to 1.1.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lark')
-rw-r--r--dev-python/lark/Manifest1
-rw-r--r--dev-python/lark/lark-1.1.9.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/lark/Manifest b/dev-python/lark/Manifest
index 97f0f458e754..9731015499a0 100644
--- a/dev-python/lark/Manifest
+++ b/dev-python/lark/Manifest
@@ -1 +1,2 @@
DIST lark-1.1.8.tar.gz 255316 BLAKE2B 40f0590ee313e5da57e593fe1cd311dfe1222cea1be83c5d1686d9a74983c8abc4f4f913f456993c51df4ce79eced10412ff9bf3dfafbeaa30f11e1301c84f60 SHA512 e51ecb38d9e7c25cca2845c56cd3cce1b1b3940ec8f0e135373726ffb23bda46f750b03f0f0b8edc750794c2b2aab9c327ff9f381faaabd53f09e76760548957
+DIST lark-1.1.9.tar.gz 255451 BLAKE2B 0bdb34a75c17800cc6819413011de879a163317c7414b260e1a4a0ccc4b40d11636fad1ae84946e0408096525b6cfeb6f725c95caed8043d3dff3e318d15be1f SHA512 4d711451f129312a28cff84239a2928fdff96df1445f77ae7a9d882d13791a58e44663ef70fd064df954094878214611ee1313ce9315c8dcfb0833b003a3774f
diff --git a/dev-python/lark/lark-1.1.9.ebuild b/dev-python/lark/lark-1.1.9.ebuild
new file mode 100644
index 000000000000..b76ccddaa86d
--- /dev/null
+++ b/dev-python/lark/lark-1.1.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
+HOMEPAGE="
+ https://github.com/lark-parser/lark/
+ https://pypi.org/project/lark/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require dev-python/js2py which is a really bad quality package
+ tests/test_nearley/test_nearley.py
+ )
+
+ if has "${EPYTHON}" pypy3 python3.{8,9}; then
+ EPYTEST_IGNORE+=(
+ # test using Python 3.10+ syntax
+ tests/test_pattern_matching.py
+ )
+ fi
+
+ epytest
+}