summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-16 23:11:27 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-16 23:34:09 +0100
commit25d74e08bf439c5b50ea41b42adf4aeb548d0964 (patch)
tree09d2434a1e465848a14b602ed00423297e258aeb /dev-python/krb5
parentdev-python/redis-py: Bump to 4.1.4 (diff)
downloadgentoo-25d74e08bf439c5b50ea41b42adf4aeb548d0964.tar.gz
gentoo-25d74e08bf439c5b50ea41b42adf4aeb548d0964.tar.bz2
gentoo-25d74e08bf439c5b50ea41b42adf4aeb548d0964.zip
dev-python/krb5: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/krb5')
-rw-r--r--dev-python/krb5/Manifest1
-rw-r--r--dev-python/krb5/krb5-0.3.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/krb5/Manifest b/dev-python/krb5/Manifest
index ef4472eb7e6a..84a00a6c9f81 100644
--- a/dev-python/krb5/Manifest
+++ b/dev-python/krb5/Manifest
@@ -1 +1,2 @@
DIST krb5-0.2.0.tar.gz 1086940 BLAKE2B af0028f91fc86bba3a450cfb09d1da31d976670f844f46b6a3c7dbddeaa8a4d4cffcde21fa076b5ae5f740052cd60b3872d10174eae3613181f9a3f4d6c9841f SHA512 f2e8558f5800467e362798092f1f37268558d9890491f1d808b51ac2f5372f0b495ce19d1addc74da663eef1baf838ac514b74b5cbc5cf262925bdca2d7231a9
+DIST krb5-0.3.0.tar.gz 1707212 BLAKE2B 0fa7a60372876f28cdbc2865fbd898c717aaaf22837bfd123008611973a0d6907ea9e5941d5da4ef707161d6aadd883fdef1faab81d307153eb4e115defe32a6 SHA512 5074cecfcd82c8f525d77c2faba5b34d6cdc593b15124741df1adec64cdde59fec2f17a02c04f78484ab4b82f7f37f5c1a4d856a2040c8d11c7e4a1b74307b27
diff --git a/dev-python/krb5/krb5-0.3.0.ebuild b/dev-python/krb5/krb5-0.3.0.ebuild
new file mode 100644
index 000000000000..2f970f72d609
--- /dev/null
+++ b/dev-python/krb5/krb5-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Kerberos API bindings for Python"
+HOMEPAGE="https://pypi.org/project/krb5/ https://github.com/jborean93/pykrb5"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ virtual/krb5
+"
+BDEPEND="
+ test? ( dev-python/k5test[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest