summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 06:38:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:17 +0200
commit07c2b0de2094c151983c3fb9e0f04103ae139c8c (patch)
tree11c804e74ede67d31b7a823ee67273169f474930 /dev-python/keyring
parentdev-python/tox: Bump to 4.6.3 (diff)
downloadgentoo-07c2b0de2094c151983c3fb9e0f04103ae139c8c.tar.gz
gentoo-07c2b0de2094c151983c3fb9e0f04103ae139c8c.tar.bz2
gentoo-07c2b0de2094c151983c3fb9e0f04103ae139c8c.zip
dev-python/keyring: Bump to 24.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-24.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 6bad012465c2..6e05dd3e3eaf 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1,2 @@
DIST keyring-23.13.1.tar.gz 59582 BLAKE2B fb39490ba857f97b9b89856059664dfe21495ffe651bb48ad4e2284efe3f3c7551d34bfb4c39518c2b9b5e31e61b91693301271750f4ec837567d7652b11e9ef SHA512 7e56380e7311a31d8703b9e3beb74a8c8ce026f6cf9e1792780d349f3db61f50a1905c7d509a7013dd7cb47428dd3c28c3620815f01d3c4dbd7f648e056539d0
+DIST keyring-24.0.0.tar.gz 59671 BLAKE2B 424247f21958c5f485de2a4eca3d0cabcb2eec3b80ab3492f15ce1c0df3ff33131453387083da2119aaac7368153a59c31ad1919d7f350f62b1cfa367b9f0eed SHA512 4e6ce15d43aadbb831005e9b8f5cdebe4c034d9e2e47798814ae83d8146226504147585b8bfcb10ee5461113bd45d296f41c8c2bbf6fd30665192051b937ef05
diff --git a/dev-python/keyring/keyring-24.0.0.ebuild b/dev-python/keyring/keyring-24.0.0.ebuild
new file mode 100644
index 000000000000..b53edb187cea
--- /dev/null
+++ b/dev-python/keyring/keyring-24.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.11.4[${PYTHON_USEDEP}]
+ ' 3.9 3.10 3.11)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)