summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/kaa-imlib2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/kaa-imlib2')
-rw-r--r--dev-python/kaa-imlib2/Manifest1
-rw-r--r--dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch11
-rw-r--r--dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild31
-rw-r--r--dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r2.ebuild25
-rw-r--r--dev-python/kaa-imlib2/metadata.xml11
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/kaa-imlib2/Manifest b/dev-python/kaa-imlib2/Manifest
new file mode 100644
index 000000000000..500e52abdf54
--- /dev/null
+++ b/dev-python/kaa-imlib2/Manifest
@@ -0,0 +1 @@
+DIST kaa-imlib2-0.2.3.tar.gz 30671 SHA256 44eec202450edadfdac91a44be191b7fbba6225e90a6595443c422d1928f39c6 SHA512 417e473befba7360160db8296fb20de9689f6620bf0940b35e68b4abf00ec49ffadf95f62b7c6baaf1465b6c69c2d14b149d9ff3a4a8450e5966cf53f160a5a0 WHIRLPOOL 480d3e0b51cb93c4c53c6734844e6fddbfba3ed81e0d4b40493e254c39375276e3d52c108cef488f8551d58e73a196d8bb3a3e73a48e9fcf98d1158106c10e9d
diff --git a/dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch b/dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch
new file mode 100644
index 000000000000..0db6fefa9ca8
--- /dev/null
+++ b/dev-python/kaa-imlib2/files/kaa-imlib2-remove-png-dep.patch
@@ -0,0 +1,11 @@
+--- setup.py.old 2008-07-12 01:43:30.700296071 +0200
++++ setup.py 2008-07-12 01:43:57.441547566 +0200
+@@ -39,7 +39,7 @@
+ sys.exit(1)
+
+ files = [ 'src/imlib2.c', 'src/image.c', 'src/font.c', 'src/rawformats.c' ]
+-libraries = [ 'png']
++libraries = []
+ if not os.uname()[0] in ('FreeBSD', 'Darwin'):
+ libraries.append('rt')
+ imlib2so = Extension('kaa.imlib2._Imlib2module', files,
diff --git a/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..d787a39d3a96
--- /dev/null
+++ b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* 2.7-pypy-* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Imlib2 wrapper for Python"
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-python/kaa-base-0.3.0
+ dev-libs/libxml2[python]
+ media-libs/imlib2"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="kaa"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/kaa-imlib2-remove-png-dep.patch"
+}
diff --git a/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r2.ebuild b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..8a5d9aace534
--- /dev/null
+++ b/dev-python/kaa-imlib2/kaa-imlib2-0.2.3-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Imlib2 wrapper for Python"
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/kaa-base-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python]
+ media-libs/imlib2"
+RDEPEND="${DEPEND}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}/kaa-imlib2-remove-png-dep.patch" )
diff --git a/dev-python/kaa-imlib2/metadata.xml b/dev-python/kaa-imlib2/metadata.xml
new file mode 100644
index 000000000000..1a1352521491
--- /dev/null
+++ b/dev-python/kaa-imlib2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ Kaa-Imlib2 is a python module for Imlib2.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">freevo</remote-id>
+ </upstream>
+</pkgmetadata>