summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:45:00 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-29 15:52:33 +0200
commitd92dd67f489b9df254df9857ab1d11a5dd5432da (patch)
treeea8b9858a10669be72183cc0347ea2158de40b56 /dev-python/jupyterlab
parentapp-text/kramdown-rfc: drop 1.6.18 (diff)
downloadgentoo-d92dd67f489b9df254df9857ab1d11a5dd5432da.tar.gz
gentoo-d92dd67f489b9df254df9857ab1d11a5dd5432da.tar.bz2
gentoo-d92dd67f489b9df254df9857ab1d11a5dd5432da.zip
dev-python/jupyterlab: add 3.6.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest1
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.6.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index d4444e661d80..0b6da7129920 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-3.5.3.tar.gz 17114007 BLAKE2B 70d32721a2579331dd4e3481f7241f5e2c5aad6dac851f213de0ac1fc3b76667bea496bca5ea13ee562e9678d51ac45df91c5901d8d3b7dc839977d3d842e67d SHA512 fdacd34ab629da2b5c2eb23f11ba4d44d5b27872e1736850319bcabbe635d31cfa2891c1c5991b152a5c1d94221e3766a20fc91033f556d8e508374bc46d5fe2
DIST jupyterlab-3.6.1.tar.gz 16845937 BLAKE2B 41c50a9ddefc0ec97c70843e15107d3e3cebfadea2ec148e4536407b0f1b202c2aeace794b02c7cb666c316434da614c1bfebab5e5fc7e654f62677bac6e1eb3 SHA512 9dc63162955c13721c97d620a60116cd75bf10eca9c8eab08ae35749bf2dfec84c55759a361ca1abab34c44d63eded95748cfea589aff98907045b483d778413
+DIST jupyterlab-3.6.2.tar.gz 16846937 BLAKE2B 1b443ace53a68903728aa781a0a0aa95a13193b63ce3101144945e41245dd7c00554abc6c75a48feafc677d83580705393cde1a4bffab0e09d2d5bf0d67e72e0 SHA512 8ca7956f6c78413a7aecb55cd60b3dfa8491afbe3b02d9ae5b038ba4dcc762daf78768349cb586775483e8dee39d5a062650d0fd156e12a85383543f836cfb38
diff --git a/dev-python/jupyterlab/jupyterlab-3.6.2.ebuild b/dev-python/jupyterlab/jupyterlab-3.6.2.ebuild
new file mode 100644
index 000000000000..7f9e59dbde57
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.6.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.16[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_ydoc-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-ydoc-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ test? (
+ dev-python/check-manifest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/openapi-core[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}