summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-21 19:57:34 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-21 20:02:29 +0100
commit2523dff2466ce3b91b0ed606d797be072ee27c8c (patch)
treeb0f9210488e4fc7079d5e3fb39719aa7872219bf /dev-python/jupyterlab-lsp
parentdev-python/jupyterlab_server: add version 2.10.3 (diff)
downloadgentoo-2523dff2466ce3b91b0ed606d797be072ee27c8c.tar.gz
gentoo-2523dff2466ce3b91b0ed606d797be072ee27c8c.tar.bz2
gentoo-2523dff2466ce3b91b0ed606d797be072ee27c8c.zip
dev-python/jupyterlab-lsp: add version 3.10.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index f570093e2000..2225154a0779 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,3 +1,4 @@
+DIST jupyterlab-lsp-3.10.0.tar.gz 269237 BLAKE2B 379716c2dc61053f10b70969b63a62b3d8c57915c472ee04f55513236f318d787ae92257751f789a2a7fe3b6faef5141e54ef7708c76f7720eabe8edf855a28e SHA512 a62073744a6ab5d57af12e738ef754f139bf34fdcbd54921127a1273f238cbda3f9ac859f7702ab862ba5597dcd75d22c0db9423ef6c7b2ee9c3459efda3b2a5
DIST jupyterlab-lsp-3.9.1.tar.gz 262645 BLAKE2B cd3377ea3abbb3f877b257140d5ac6b162aa9d4229cb58f67fa60a9b7f5db43de6873af381bac5bbf6103a47a53863ae322ad200550d73e5c19baa5eb2866aa2 SHA512 0289dc666a3ec3d93d276c67e95c19b0427e45a4f1e001180df4af9a72f7e81dddc8bdd175684f857dfc8e02935dbd31b454bfd0ee1431a8e702f662365c747e
DIST jupyterlab-lsp-3.9.2.tar.gz 263499 BLAKE2B 2ece934e68b27e28161ee3218af2d11bd5b286b4c517ff8feb4f9ec10c261e51a95fb4d52de7717d896a7c4dbca9be168aa75ed8ab7728dd4844640417f31365 SHA512 c41045736cbf511f72668dc03c0fd1265c2b2e2f60a4e987fecd8e23be0a6af1ae7b341f6b0c47fb4f5956f00cbb982f8cd9f31ebca8098ce01cc21a8f0df357
DIST jupyterlab-lsp-3.9.3.tar.gz 263515 BLAKE2B 0e2c4c13d6959d24357d140c0484494d1e2922864cf7c4ab58dff886560b627f2648f6cd2ac9f7fe64e3d86f0d26dfc76f413b376c6d2663df3f1396bcaf7fcf SHA512 4009ddd1754a74d031f91b29743c9a9ad21bb5260af066390e9987bca211a34d4a6f96ff863b4ab408133cea3df9464ea17bc3ff5cb5306b3ddfcba937843897
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.0.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.0.ebuild
new file mode 100644
index 000000000000..46148aa982dc
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.10.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.1.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-1.4.0[${PYTHON_USEDEP}]
+"