summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 02:56:54 +0000
committerSam James <sam@gentoo.org>2021-03-04 02:56:54 +0000
commiteef14daf66720ca9679f079b446ef99f8619e952 (patch)
treebbdd00b443059762c979ab4e28fcefc6841f22b6 /dev-python/jsonref
parentmedia-libs/xine-lib: fix automagic on nfs, libssh2, wayland (diff)
downloadgentoo-eef14daf66720ca9679f079b446ef99f8619e952.tar.gz
gentoo-eef14daf66720ca9679f079b446ef99f8619e952.tar.bz2
gentoo-eef14daf66720ca9679f079b446ef99f8619e952.zip
dev-python/jsonref: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/jsonref')
-rw-r--r--dev-python/jsonref/jsonref-0.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/jsonref/jsonref-0.1.ebuild b/dev-python/jsonref/jsonref-0.1.ebuild
index 9010d34f9a39..9459df117774 100644
--- a/dev-python/jsonref/jsonref-0.1.ebuild
+++ b/dev-python/jsonref/jsonref-0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit eutils distutils-r1
@@ -15,10 +15,8 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
python_test() {
pytest -vv tests.py || die