summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-18 09:52:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-18 15:02:42 +0200
commit7da97dd42c206c58e699c10d31d8abe82f6d16dc (patch)
tree283542231af39941b4b6d71b71479818431a1484 /dev-python/jellyfish
parentdev-python/unicodecsv: Port to python3.10 (diff)
downloadgentoo-7da97dd42c206c58e699c10d31d8abe82f6d16dc.tar.gz
gentoo-7da97dd42c206c58e699c10d31d8abe82f6d16dc.tar.bz2
gentoo-7da97dd42c206c58e699c10d31d8abe82f6d16dc.zip
dev-python/jellyfish: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jellyfish')
-rw-r--r--dev-python/jellyfish/jellyfish-0.8.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/jellyfish/jellyfish-0.8.2.ebuild b/dev-python/jellyfish/jellyfish-0.8.2.ebuild
index a7c44116c5b2..39fa8d842c5d 100644
--- a/dev-python/jellyfish/jellyfish-0.8.2.ebuild
+++ b/dev-python/jellyfish/jellyfish-0.8.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
@@ -14,7 +14,7 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 x86"
-DEPEND="
+BDEPEND="
test? (
dev-python/unicodecsv[${PYTHON_USEDEP}]
)
@@ -26,5 +26,5 @@ distutils_enable_tests pytest
python_test() {
cp -r testdata "${BUILD_DIR}" || die
cd "${BUILD_DIR}" || die
- pytest -vv lib/jellyfish/test.py || die "tests failed with ${EPYTHON}"
+ epytest lib/jellyfish/test.py
}