summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-11 08:03:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-11 08:17:53 +0200
commitab624cb169706e6d24487f9d25966bd7e3099197 (patch)
tree165a8d3debde54100d280f97f505b19149a34ad6 /dev-python/jeepney
parentmedia-sound/qtractor: bump to 0.9.23 (diff)
downloadgentoo-ab624cb169706e6d24487f9d25966bd7e3099197.tar.gz
gentoo-ab624cb169706e6d24487f9d25966bd7e3099197.tar.bz2
gentoo-ab624cb169706e6d24487f9d25966bd7e3099197.zip
dev-python/jeepney: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jeepney')
-rw-r--r--dev-python/jeepney/Manifest1
-rw-r--r--dev-python/jeepney/jeepney-0.7.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index 9a0370021b93..a37ec86c12fd 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1 +1,2 @@
DIST jeepney-0.6.0.tar.gz 49513 BLAKE2B e5f9b5104cf07dbcd2d40c2d22b690dfd56c456ab56daf44f4abee83f0bfe7e1dfbad797348044d51e3dc20fbc6ce68bf8df54f9c1e46d7a86ceb22d3ab30f8d SHA512 140be9dd28ed853d2d41b6a8bbeb2f22c0270ce7bf33b943ec2ac010db17d4f06e253fa8637fbbb3044fe9ffdbfa1e15f0c663eb44bdd538f8c47c2e7dab3ca5
+DIST jeepney-0.7.0.tar.gz 61236 BLAKE2B ec477ed0d96d7d82a256c7f62900eff0282ebec4545e30807fd62cffb419ed763fd8042bdd4d72c6cf43ac09d24af9cd86797b1baec61ad5965e51b3d669175d SHA512 b1fac480da0d8798b28eae30cb22ee97d4f73a11922f7b1bce86eebf938c2980414c2d026ef5a1cdcd95813724873700d348b04ba337aaac0706b2c8b38ea6c2
diff --git a/dev-python/jeepney/jeepney-0.7.0.ebuild b/dev-python/jeepney/jeepney-0.7.0.ebuild
new file mode 100644
index 000000000000..3183dc86128e
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ $(python_gen_cond_dep '
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local ignore=()
+ # keep in sync with python_gen_cond_dep!
+ if ! has "${EPYTHON}" python3.{8..9}; then
+ ignore+=( jeepney/io/tests/test_trio.py )
+ fi
+
+ dbus-run-session pytest -vv -ra -l ${ignore[@]/#/--ignore } ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}