summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 21:36:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 21:39:54 +0300
commita524a67ba9f87caa52cc664b0e593d7a728a0ef7 (patch)
tree688cabb896281c3e10d115a0142b09450a64dd6e /dev-python/jdcal
parentmedia-libs/libass: add 0.16.0 (diff)
downloadgentoo-a524a67ba9f87caa52cc664b0e593d7a728a0ef7.tar.gz
gentoo-a524a67ba9f87caa52cc664b0e593d7a728a0ef7.tar.bz2
gentoo-a524a67ba9f87caa52cc664b0e593d7a728a0ef7.zip
dev-python/jdcal: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jdcal')
-rw-r--r--dev-python/jdcal/jdcal-1.4.1-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/jdcal/jdcal-1.4.1-r1.ebuild b/dev-python/jdcal/jdcal-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..b189f0d9aee5
--- /dev/null
+++ b/dev-python/jdcal/jdcal-1.4.1-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Julian dates from proleptic Gregorian and Julian calendars"
+HOMEPAGE="https://github.com/phn/jdcal"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+distutils_enable_tests pytest