summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-02 10:01:34 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-04 18:11:58 +0100
commit74bad7b990e3dae2a58063dd4daa2046b1b305a2 (patch)
tree1d3f1d74cdb61db13ee47c35b25271cac853282a /dev-python/ipython
parentdev-python/ipyparallel: Remove py2 (diff)
downloadgentoo-74bad7b990e3dae2a58063dd4daa2046b1b305a2.tar.gz
gentoo-74bad7b990e3dae2a58063dd4daa2046b1b305a2.tar.bz2
gentoo-74bad7b990e3dae2a58063dd4daa2046b1b305a2.zip
dev-python/ipython: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ipython-5.4.1-r2.ebuild5
-rw-r--r--dev-python/ipython/ipython-5.8.0-r1.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/ipython/ipython-5.4.1-r2.ebuild b/dev-python/ipython/ipython-5.4.1-r2.ebuild
index 3ef033ba0f16..9f84d5ddc9e0 100644
--- a/dev-python/ipython/ipython-5.4.1-r2.ebuild
+++ b/dev-python/ipython/ipython-5.4.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
PYTHON_REQ_USE='readline,sqlite,threads(+)'
inherit distutils-r1 eutils
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test wxwidgets"
+IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
CDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]
@@ -28,7 +28,6 @@ CDEPEND="
dev-python/simplegeneric[${PYTHON_USEDEP}]
>=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
- wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' 'python2*') )
"
RDEPEND="${CDEPEND}
diff --git a/dev-python/ipython/ipython-5.8.0-r1.ebuild b/dev-python/ipython/ipython-5.8.0-r1.ebuild
index da8707c9aa62..f30f2232d004 100644
--- a/dev-python/ipython/ipython-5.8.0-r1.ebuild
+++ b/dev-python/ipython/ipython-5.8.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
PYTHON_REQ_USE='readline,sqlite,threads(+)'
inherit distutils-r1 eutils virtualx
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test wxwidgets"
+IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
RESTRICT="!test? ( test )"
CDEPEND="
@@ -29,7 +29,6 @@ CDEPEND="
dev-python/simplegeneric[${PYTHON_USEDEP}]
>=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
- wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' 'python2*') )
"
RDEPEND="${CDEPEND}