summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/into
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/into')
-rw-r--r--dev-python/into/Manifest3
-rw-r--r--dev-python/into/into-0.1.3.ebuild19
-rw-r--r--dev-python/into/into-0.2.1.ebuild26
-rw-r--r--dev-python/into/into-0.2.2.ebuild26
-rw-r--r--dev-python/into/metadata.xml8
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/into/Manifest b/dev-python/into/Manifest
new file mode 100644
index 000000000000..26deb47453e6
--- /dev/null
+++ b/dev-python/into/Manifest
@@ -0,0 +1,3 @@
+DIST into-0.1.3.tar.gz 31161 SHA256 a92642e2a7372b477488c9d92c3e4d03b5412908dd291dd85020a7eb97c49d44 SHA512 a201ab8b2b2e4d2455232edde35bdbbdbf8432152ec6f7084300af7ee8960d476c00326342c0a658b0a8873a3a0ee025cf24b87b4ae45fa4f1d94db7a5a374ef WHIRLPOOL 894b9045917c06c5540c248415f0b4ae1cd2e86d979417f23589a0b41ecc726f5a55d54b9bcc1808370344b6be31c277efaeec5c2c13bc8e3e960ac38345aa17
+DIST into-0.2.1.tar.gz 75510 SHA256 bf4a8d7c4141984ba5db201e076d5ecfdb3a32c0f8ca311d4f49b030fcb04a2f SHA512 3df1a55f2a8881c1d952baeb5484d93245085bff02a38266b9ca478ade8cce23c0b16b6be690ada7e279f0f22ea9adf934a0105cbea2ce4d243e03fc73cc1c9e WHIRLPOOL a5e5dd5845e2dd741165fd484b4314c05539a95b76f840e8b71acb3c42aaaf8e2a01a34ca6881a79cc6db5b2b19b2c8413489469a8af2fee188841f2e0a3a474
+DIST into-0.2.2.tar.gz 85008 SHA256 8a6d5595625a1c2de0732ba4448c554b707a8259b477c9b0b7bb94a1f1ca887b SHA512 0dc43e55dcbb6264c226c1b4d893b07fee9e90304e293953b26764d90ba211ed65eddad68c7fe4f2eebe7b57595bbd12131665394ce4f339da0cf77337ed16e2 WHIRLPOOL 49da50cc994788037ac4edd5f5c44802a2263f30184bfe4d64810395efa97283e1741ef879e9b883a0b02ed2732eb280448d339f55cafa501706fd8b2f2afdfa
diff --git a/dev-python/into/into-0.1.3.ebuild b/dev-python/into/into-0.1.3.ebuild
new file mode 100644
index 000000000000..5eb180a7b716
--- /dev/null
+++ b/dev-python/into/into-0.1.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data migration utilities"
+HOMEPAGE="https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="!media-libs/urt" # Bug #552448
diff --git a/dev-python/into/into-0.2.1.ebuild b/dev-python/into/into-0.2.1.ebuild
new file mode 100644
index 000000000000..a6c987090a87
--- /dev/null
+++ b/dev-python/into/into-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data migration utilities"
+HOMEPAGE="https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/datashape[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ !media-libs/urt" # Bug #552448
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/into/into-0.2.2.ebuild b/dev-python/into/into-0.2.2.ebuild
new file mode 100644
index 000000000000..a6c987090a87
--- /dev/null
+++ b/dev-python/into/into-0.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data migration utilities"
+HOMEPAGE="https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/datashape[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.15[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ !media-libs/urt" # Bug #552448
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/into/metadata.xml b/dev-python/into/metadata.xml
new file mode 100644
index 000000000000..756e541deb1d
--- /dev/null
+++ b/dev-python/into/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">into</remote-id>
+ </upstream>
+</pkgmetadata>