summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-12 20:09:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-12 20:27:57 +0200
commited6f858093781375f7d51f896629832facec75c3 (patch)
tree999d4ac33a4146eeb0dbd6943524c125d0495975 /dev-python/iniparse
parentdev-python/ipy: Enable py3.11 (diff)
downloadgentoo-ed6f858093781375f7d51f896629832facec75c3.tar.gz
gentoo-ed6f858093781375f7d51f896629832facec75c3.tar.bz2
gentoo-ed6f858093781375f7d51f896629832facec75c3.zip
dev-python/iniparse: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iniparse')
-rw-r--r--dev-python/iniparse/iniparse-0.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/iniparse/iniparse-0.5-r1.ebuild b/dev-python/iniparse/iniparse-0.5-r1.ebuild
new file mode 100644
index 000000000000..68e15ebdd7b0
--- /dev/null
+++ b/dev-python/iniparse/iniparse-0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Better INI parser for Python"
+HOMEPAGE="
+ https://github.com/candlepin/python-iniparse/
+ https://pypi.org/project/iniparse/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die
+}