summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-26 10:52:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-26 11:37:35 +0100
commitd9df9363ac2eb251d96356975523d397c5540e5b (patch)
tree622f08cfe91fad3eda3a4472ae3355489699d56e /dev-python/importlib_resources
parentdev-python/immutables: Bump to 0.17 (diff)
downloadgentoo-d9df9363ac2eb251d96356975523d397c5540e5b.tar.gz
gentoo-d9df9363ac2eb251d96356975523d397c5540e5b.tar.bz2
gentoo-d9df9363ac2eb251d96356975523d397c5540e5b.zip
dev-python/importlib_resources: Bump to 5.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.6.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index cfaeebb06a0e..238c23cd7aab 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1 +1,2 @@
DIST importlib_resources-5.4.0.tar.gz 30554 BLAKE2B f5be47cb63813aea15f65d251115cf398f695041871fdf6e8885fee11d9a9d7a2fbfd07efd494bd7c91077f99ab871e06d45f49de9f7e501a1691601206bfb55 SHA512 9262c185bdf79fad0a11caabc5c5df836702a74e140a9f60ace857e3f6a60fdb091639b2fb7129b17bad5a46968f43dda7d176fe39af495370dd31f04891fb1b
+DIST importlib_resources-5.6.0.tar.gz 30846 BLAKE2B 9a83554cd65b7851c4a8c977509f3fc255de3c5927661764e702eeae142b7d0cc75f809fe2a438b6f3acdb2facbdc3dadbf3f9dfed5615643dc15e04545dcf8c SHA512 d3c88dd5f1877b205b4c53ab9c8d4180ae87be0ff9dd11483024de40c84fe7da359f70337aeacc5df3b6deca88b903bb01850da8a54fd057e4174806ae767deb
diff --git a/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild b/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild
new file mode 100644
index 000000000000..31f3ce7d8000
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://github.com/python/importlib_resources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/zipp-3.7.0-r1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}