summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/imdbpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/imdbpy')
-rw-r--r--dev-python/imdbpy/Manifest2
-rw-r--r--dev-python/imdbpy/files/imdbpy-4.6-data_location.patch11
-rw-r--r--dev-python/imdbpy/imdbpy-4.9-r1.ebuild42
-rw-r--r--dev-python/imdbpy/imdbpy-5.0.ebuild42
-rw-r--r--dev-python/imdbpy/metadata.xml8
5 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/imdbpy/Manifest b/dev-python/imdbpy/Manifest
new file mode 100644
index 000000000000..49be0a824901
--- /dev/null
+++ b/dev-python/imdbpy/Manifest
@@ -0,0 +1,2 @@
+DIST IMDbPY-4.9.tar.gz 307726 SHA256 01e90dce4fe19aeca99c9d3eb14052769467b177e3fb8acc240f9c51c5f477d2 SHA512 1f46ea504e7ca61b0e8ba85bd2bfd88ef2ddc87f085d70336773d840401b03d6a8b807544ee665f4211ca093dc23dbc69619b5c04cab0b5024e73105179be8f4 WHIRLPOOL bb289000fe267124dfa1ee331a0c48722c5799b241d281e39483e73a8650804596d37922d516ad92ca2ca4ef140ff59d80bda99fbd2cbbd67e9bbe8222bbabb6
+DIST IMDbPY-5.0.tar.gz 367238 SHA256 3224a8896847cddb8d049a587852c66f0f33f36c89311ae9a89ff87ed51fc243 SHA512 924b9c9b7055c75abb1c48867ba9ccef3c5259c748a6f21e8344616da9ea58d5ae58a2f12a78dc61fea7c008956994687fdcf7ecd59f5f4e82daea62890086d4 WHIRLPOOL 5cae4a26734c10c3c21bc2f1be4fa5efca8e82a2cf78249c359f7e3c8bb8e12f1fefc535796f98d5b23b6c3174e11ac40f8e56749c93c859c7f63e052af6402f
diff --git a/dev-python/imdbpy/files/imdbpy-4.6-data_location.patch b/dev-python/imdbpy/files/imdbpy-4.6-data_location.patch
new file mode 100644
index 000000000000..90dc467170eb
--- /dev/null
+++ b/dev-python/imdbpy/files/imdbpy-4.6-data_location.patch
@@ -0,0 +1,11 @@
+--- setup.py
++++ setup.py
+@@ -70,7 +70,7 @@
+
+ # XXX: I'm not sure that 'etc' is a good idea. Making it an absolute
+ # path seems a recipe for a disaster (with bdist_egg, at least).
+-data_files = [('doc', setuptools.findall('docs')), ('etc', ['docs/imdbpy.cfg'])]
++data_files = [('/etc', ['docs/imdbpy.cfg'])]
+
+
+ # Defining these 'features', it's possible to run commands like:
diff --git a/dev-python/imdbpy/imdbpy-4.9-r1.ebuild b/dev-python/imdbpy/imdbpy-4.9-r1.ebuild
new file mode 100644
index 000000000000..3f61d264cc6c
--- /dev/null
+++ b/dev-python/imdbpy/imdbpy-4.9-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="IMDbPY"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python package to access the IMDb movie database"
+HOMEPAGE="http://imdbpy.sourceforge.net/ http://pypi.python.org/pypi/IMDbPY"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( docs/FAQS.txt docs/imdbpy48.dtd docs/imdbpy.cfg )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6-data_location.patch" )
+
+src_configure() {
+ distutils-r1_src_configure --without-cutils
+}
+
+python_install_all() {
+ local doc
+ for doc in docs/README*
+ do
+ DOCS=( "${DOCS[@]}" $doc )
+ done
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/imdbpy/imdbpy-5.0.ebuild b/dev-python/imdbpy/imdbpy-5.0.ebuild
new file mode 100644
index 000000000000..3f61d264cc6c
--- /dev/null
+++ b/dev-python/imdbpy/imdbpy-5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="IMDbPY"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python package to access the IMDb movie database"
+HOMEPAGE="http://imdbpy.sourceforge.net/ http://pypi.python.org/pypi/IMDbPY"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( docs/FAQS.txt docs/imdbpy48.dtd docs/imdbpy.cfg )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6-data_location.patch" )
+
+src_configure() {
+ distutils-r1_src_configure --without-cutils
+}
+
+python_install_all() {
+ local doc
+ for doc in docs/README*
+ do
+ DOCS=( "${DOCS[@]}" $doc )
+ done
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/imdbpy/metadata.xml b/dev-python/imdbpy/metadata.xml
new file mode 100644
index 000000000000..7cd64fc49e98
--- /dev/null
+++ b/dev-python/imdbpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mythtv</herd>
+ <upstream>
+ <remote-id type="pypi">IMDbPY</remote-id>
+ </upstream>
+</pkgmetadata>