summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-16 23:10:49 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-16 23:10:49 -0400
commit56c4533bede81709390b3671b3f8e9a6be8ee850 (patch)
tree71844e0c7e5e89b8993d2c1dda0f1b3ce172e7d0 /dev-python/idna
parentprofiles: adjust mask author email address (diff)
downloadgentoo-56c4533bede81709390b3671b3f8e9a6be8ee850.tar.gz
gentoo-56c4533bede81709390b3671b3f8e9a6be8ee850.tar.bz2
gentoo-56c4533bede81709390b3671b3f8e9a6be8ee850.zip
dev-python/idna: version bump to 2.7
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-2.7.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index 293df830a510..fd516b811fc3 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1,2 +1,3 @@
DIST idna-2.5.tar.gz 130211 BLAKE2B 3b00b76f9d86f0961ca4613c4239e39fa19c28f60640d2c9d9b7ea05985f9eceac122bb9e5b30b2f22648506580202a187f95513fe5ab0af6632917335f2eda0 SHA512 29a69ede25a8855135c763da5d20ff81832c710038a38521c127d5b7b24b355c6cfa5e9f9a2a4ef1fa4437537d1d9e4b448357e07b4b5e3724d98fee0a3b7835
DIST idna-2.6.tar.gz 135992 BLAKE2B 1397c93eae23a9ecbcc001205e83fd684cbdb4f0c916c30b7d80dc7fdd43c588a9a81a620a39108a31707c1aee8c4a315d1988ae5a8cf1f6519bb11bad6dc3a3 SHA512 cb5dbfab44c4d11521c67f9d29391f184d1267a3da6dc89f4ed12c60a7a909d5c7474c3ea2bddd0af7063f4f620e87a8dd586bb07e8b961b30b1dd7c969704c2
+DIST idna-2.7.tar.gz 172698 BLAKE2B d0c92988d78629af3b87b8b4842757395c1f439f25d77614ba05d48e57d7d9a414c5be33e3fcf191f7dc8fea7325c801ff9c6f687204dec3735406f6e2342923 SHA512 34ba985862e386243f43616586e53830177cf4ba0925b6054198dfa63c085ec5c6c5b54c2b3c0989bc768aacceeef76b84471e58a16183b960dc4b8812cd1c61
diff --git a/dev-python/idna/idna-2.7.ebuild b/dev-python/idna/idna-2.7.ebuild
new file mode 100644
index 000000000000..f57d72cfe473
--- /dev/null
+++ b/dev-python/idna/idna-2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna https://pypi.org/project/idna/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}