summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-16 03:29:17 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-16 03:29:17 +0200
commitbe8a641bc82d507aced3d693ec94eec94c6a5c39 (patch)
treee62611eceb094ab600ead136b8b9dfe11292eb2b /dev-python/idna/idna-2.5.ebuild
parentdev-python/distlib: Version bump to 0.2.4 (diff)
downloadgentoo-be8a641bc82d507aced3d693ec94eec94c6a5c39.tar.gz
gentoo-be8a641bc82d507aced3d693ec94eec94c6a5c39.tar.bz2
gentoo-be8a641bc82d507aced3d693ec94eec94c6a5c39.zip
dev-python/idna: Version bump to 2.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/idna/idna-2.5.ebuild')
-rw-r--r--dev-python/idna/idna-2.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/idna/idna-2.5.ebuild b/dev-python/idna/idna-2.5.ebuild
new file mode 100644
index 000000000000..4f3d92e16dc7
--- /dev/null
+++ b/dev-python/idna/idna-2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}