summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-10 10:01:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-10 11:54:03 +0100
commit84651533f447965d6479cace614ef98fcf7b3f6e (patch)
treef51b29bbd5e29e16858178251c6e3bfd3b12f7da /dev-python/hyper-h2
parentdev-python/hypothesis: Bump to 5.5.1 (diff)
downloadgentoo-84651533f447965d6479cace614ef98fcf7b3f6e.tar.gz
gentoo-84651533f447965d6479cace614ef98fcf7b3f6e.tar.bz2
gentoo-84651533f447965d6479cace614ef98fcf7b3f6e.zip
dev-python/hyper-h2: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hyper-h2')
-rw-r--r--dev-python/hyper-h2/Manifest1
-rw-r--r--dev-python/hyper-h2/hyper-h2-3.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/hyper-h2/Manifest b/dev-python/hyper-h2/Manifest
index 989f956491e8..751cd7147397 100644
--- a/dev-python/hyper-h2/Manifest
+++ b/dev-python/hyper-h2/Manifest
@@ -1,3 +1,4 @@
DIST hyper-h2-2.5.1.tar.gz 92713 BLAKE2B d00baea98dfab43c2d6157f4dec3b04b2a42d0ad280980cb8b7d03d1c6f75de59e188745e7cc29fb36fd8c0799f9d5cb50a94282c70f045289daccfdcc12dabd SHA512 e82a7e6b592b43d74defbd4c729ad287ed019881f6ddf0d2dff9d3eb4fdba29cab8d988848ec64b693da77df5cbcacb06eecf1ecd77843c66c9eea8808fc949c
DIST hyper-h2-3.0.1.tar.gz 2198911 BLAKE2B 453ce1bf8e6216e2852f49c5a22ec5cfa487a744a818e82929dd0c4f03280953c1f742890d74f771080987e2f70d9430e4d66481501357f0d4c5ec490fc5fbf7 SHA512 5d98b4fb654c20f6b9e6918bb71b88a42a3027bae795f31c32c2b5cc4428774457c44a194f9c819f99b9cfd01753a6e6d8edb6c162020ff463602452d8e9057c
DIST hyper-h2-3.1.1.tar.gz 2202601 BLAKE2B 62a7a9ff4e1295d279fbe7c02da6d60d97984caf8f4eee6fa69de3974913caf57d7933a991825296e96b54b4646139793529e839e492d440874aa134cdb7e96e SHA512 153c450ef918cc7cdb5d8efe61692a646925e76e6255ef46f679091590681be7d1f9319b37f6521c56207cf35e7d9e56951e4e3b55a24fe89d9e6aa28591957b
+DIST hyper-h2-3.2.0.tar.gz 2203333 BLAKE2B 245bab162852070e850613c41162c75efe5e43535945dacf448afdc948cade83402f77259aa46f375d0772a5287e42d8842b1259cb36392cc8fc222dec7cef75 SHA512 103a4ea2cd29037ce03ae676864125b4111c7d31a82bbbe7028557da886d88fb5363d885f08d5d3f68dfa29013b7b03350cc0cb4d9dddf32735e98dae5d7fc7c
diff --git a/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild b/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
new file mode 100644
index 000000000000..8487ab0c7c61
--- /dev/null
+++ b/dev-python/hyper-h2/hyper-h2-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="https://python-hyper.org/h2/en/stable/ https://pypi.org/project/h2/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/hyperframe-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/enum34-1.1.6[${PYTHON_USEDEP}]
+ <dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' -2)
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest -vv --hypothesis-profile=travis test ||
+ die "Tests fail with ${EPYTHON}"
+}