summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-03 09:06:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 09:27:50 +0100
commit6e616dfba31b1b7a5f88e52383b4f47531005b86 (patch)
tree18c834be3b2cefb8adbf727c3177aab269e3e3d1 /dev-python/httplib2
parentsys-libs/libomp: Pass offload-specific flags w/ USE=offload only (diff)
downloadgentoo-6e616dfba31b1b7a5f88e52383b4f47531005b86.tar.gz
gentoo-6e616dfba31b1b7a5f88e52383b4f47531005b86.tar.bz2
gentoo-6e616dfba31b1b7a5f88e52383b4f47531005b86.zip
dev-python/httplib2: Bump to 0.20.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest1
-rw-r--r--dev-python/httplib2/httplib2-0.20.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index 8fdc1b335caa..e00e914ecd83 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1 +1,2 @@
DIST httplib2-0.20.2.gh.tar.gz 407815 BLAKE2B ebb3a35b5842eff570c4d804e5dcffa5afde32841eaf1797afd47a58ff7e4d6f945b20c82ad10afe0abff1dd8c5fb405594dca0c6641f8a7a201a71258478c52 SHA512 cb1e0e365ec7872d20c1a8e3ddb150433dd01f4ec816ae2044be6aad6c21afd00ce00dfc57f1348dcc857a63e02e8ffbd39c78f35bb4bba2e283a48f07102159
+DIST httplib2-0.20.4.gh.tar.gz 371778 BLAKE2B 85e2dd0b6213cc5015d4f2f7f923209a61649f948f003eaf3c95c956cb08e6f5bf9dc4e40109c0ddea6a18ab47870a21c7d367ea1eeec2644507568f4e271005 SHA512 46396a9bb439e61939e481a2502567a6dc40686471267ea4c357f141ac138193107f90ac465db683e4ab71e5d92249b810657bff0cb74af7a37a9a23c8320741
diff --git a/dev-python/httplib2/httplib2-0.20.4.ebuild b/dev-python/httplib2/httplib2-0.20.4.ebuild
new file mode 100644
index 000000000000..0d13f9d9faa7
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.20.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/"
+SRC_URI="
+ https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ app-misc/ca-certificates
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-libs/openssl
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by using system certificates
+ tests/test_cacerts_from_env.py::test_certs_file_from_builtin
+ tests/test_cacerts_from_env.py::test_certs_file_from_environment
+ tests/test_cacerts_from_env.py::test_with_certifi_removed_from_modules
+
+ # broken by new PySocks, probably
+ tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
+ tests/test_proxy.py::test_socks5_auth
+
+ # broken by recerting (TODO)
+ tests/test_https.py::test_min_tls_version
+ tests/test_https.py::test_max_tls_version
+ )
+
+ # tests in python* are replaced by tests/
+ # upstream fails at cleaning up stuff
+ epytest tests
+}