summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-21 23:58:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-22 00:15:00 +0200
commit56bf1c363a484f004d642d736ef22ed71120b275 (patch)
tree9a6599d60e765566aa07e5b0149702f5417d0e3d /dev-python/hcs-utils
parentdev-python/colorama: version bump. (diff)
downloadgentoo-56bf1c363a484f004d642d736ef22ed71120b275.tar.gz
gentoo-56bf1c363a484f004d642d736ef22ed71120b275.tar.bz2
gentoo-56bf1c363a484f004d642d736ef22ed71120b275.zip
dev-python/hcs-utils: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/hcs-utils')
-rw-r--r--dev-python/hcs-utils/Manifest1
-rw-r--r--dev-python/hcs-utils/hcs-utils-2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/hcs-utils/Manifest b/dev-python/hcs-utils/Manifest
index 231a2be0adb6..471e6a2e9e5a 100644
--- a/dev-python/hcs-utils/Manifest
+++ b/dev-python/hcs-utils/Manifest
@@ -1 +1,2 @@
DIST hcs_utils-1.5.tar.gz 23316 SHA256 745614347855f8edc7fb1659032166f0a2285cfc8383607aa3f1bf9959525fb4 SHA512 9a8fdddc47e5b4f89d52b59af66594e9b9a3adcf9d0ca5894111a0d359e8c18930e2d38027acfacadbdbf874a281d0f2ce88b310dacbab1f2a39c03bb2fe6fbf WHIRLPOOL 1ee476f1112557b8808d6cb5163b419d3b86db8b64d49bc9bf34f878eb0ba0e14ff278dad599b2a7c51d015fb98bc92be0d0a361a372b668c18c9d23dfa09959
+DIST hcs_utils-2.0.tar.gz 38187 SHA256 e2c29c4a0498cfe6c560a74e11087752c2ab08036a5f74677214699f6132b813 SHA512 63b2ab16c8e517563dbcac4b85e781da5bd40fe20b5c41c449a20c07da5539ac37b622d7bf4d421f3721ed13bf4227aa9ebd5607280147f3723c31ce965d23f2 WHIRLPOOL 23b12eb73c3f75a238ef15fc02407a046e51ab1851dc1d9d76bf13916462729ff9d7f2c17ad32aaede436447ba8374290b5cd5b5f1050636cfc86d5a8f63664f
diff --git a/dev-python/hcs-utils/hcs-utils-2.0.ebuild b/dev-python/hcs-utils/hcs-utils-2.0.ebuild
new file mode 100644
index 000000000000..5d17911fb1d5
--- /dev/null
+++ b/dev-python/hcs-utils/hcs-utils-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A library containing some useful snippets"
+HOMEPAGE="https://pypi.python.org/pypi/hcs_utils"
+SRC_URI="mirror://pypi/h/${PN/-/_}/${MY_P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P/-/_}"
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ py.test --doctest-modules hcs_utils || die "Tests failed"
+}