summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-19 23:15:11 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-20 00:25:32 -0700
commit371831a1635ba9e7d691dd1567f99424bed26643 (patch)
treea0268ca5fe6fe28dadca109f08025bcbd93d8269 /dev-python/grpcio/grpcio-1.28.1.ebuild
parentnet-libs/grpc: bump to 1.28.1 (diff)
downloadgentoo-371831a1635ba9e7d691dd1567f99424bed26643.tar.gz
gentoo-371831a1635ba9e7d691dd1567f99424bed26643.tar.bz2
gentoo-371831a1635ba9e7d691dd1567f99424bed26643.zip
dev-python/grpcio: bump to 1.28.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio/grpcio-1.28.1.ebuild')
-rw-r--r--dev-python/grpcio/grpcio-1.28.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/grpcio/grpcio-1.28.1.ebuild b/dev-python/grpcio/grpcio-1.28.1.ebuild
new file mode 100644
index 000000000000..3a7c37294781
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.28.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_configure_all() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}