summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-23 08:58:04 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-23 09:58:41 +0100
commitb37639a968f7493ae82cc35e4604606703fd232c (patch)
tree30cad90eddab01076989bb91342ff3758f4d805c /dev-python/google-api-python-client
parentdev-python/pygit2: Bump to 1.9.1 (diff)
downloadgentoo-b37639a968f7493ae82cc35e4604606703fd232c.tar.gz
gentoo-b37639a968f7493ae82cc35e4604606703fd232c.tar.bz2
gentoo-b37639a968f7493ae82cc35e4604606703fd232c.zip
dev-python/google-api-python-client: Bump to 2.42.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.42.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 987e7c7d50fd..acf4ffd522ef 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -2,3 +2,4 @@ DIST google-api-python-client-2.37.0.tar.gz 28868090 BLAKE2B 971fa3a873c902a34c1
DIST google-api-python-client-2.38.0.tar.gz 29194978 BLAKE2B 741cf925256f0bd648e68c339233cfc13a9eaa12e123e202eab64b8389bc493755838c3da8ca4e7f4ffeecacec783c41f37df1847edf0fb54387d58163c112fc SHA512 b93f1f946ebab226b9fdd9012c3ae70563197a895d9069f09c7eb8926cd8fe5567535d3677a6824f66720b9ed1f0a732f02be9440dc800a13cb7e335728a3ce8
DIST google-api-python-client-2.40.0.tar.gz 29463380 BLAKE2B f70067d3afe614e34cf84480d7a653620b516689560033cf3ad72a963e53c76632d1254ed1ac5f492e9e4639a6d717889f0f84c283363892efa99ce1007bbb82 SHA512 ae345d46bcb13509dd631039079c3ef96899899c206bc19b47a873d8ebc9372e70f55bcada1c8ba9775d826dbe8b1fde96a8f496f5574bb15b3c73c7d848f189
DIST google-api-python-client-2.41.0.tar.gz 29608471 BLAKE2B 5a6f9eb414f02b9528d0ee8f8777da6596bd298f6aea8191966d1ebaa67219f8ea2e44a77bc667bfedab39c4ab0352a13ba04fd805f0df9a6936247cd4cf3481 SHA512 b9ee6a4374438d019d0efd09d02426c1c773fd2ca561e2bf91e426535fec2865a47a32cc5cf780e5e7da193ca3d8b5677339fee2a4983e7f4af9612d901c883d
+DIST google-api-python-client-2.42.0.tar.gz 29772877 BLAKE2B f478a719c3a6ef2f78d1fa16c231d47f2d72b55e67746612579f644b92dbd93ebd7f320f0684d85c1c1e253ed2f5163d7f6ce2904343bbe7a4f6746889663970 SHA512 e55cd75dec478a3410829a7eb7ee5478b52b44450d4ade69e3a7ee11b30e5ab5690c93ff6444f4b723db6cd1f26ac70553b3f1b9c77dc0b428db271b773faa9f
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.42.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.42.0.ebuild
new file mode 100644
index 000000000000..8c829ff884d3
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.42.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}