summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-26 03:34:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-26 03:53:02 +0200
commit26a22073d6596c6d94169b2de97e049f90b9f810 (patch)
tree142ac3820a553d7a769981f20666db6866e01d2c /dev-python/google-api-python-client
parentdev-python/sqlglot: Remove old (diff)
downloadgentoo-26a22073d6596c6d94169b2de97e049f90b9f810.tar.gz
gentoo-26a22073d6596c6d94169b2de97e049f90b9f810.tar.bz2
gentoo-26a22073d6596c6d94169b2de97e049f90b9f810.zip
dev-python/google-api-python-client: Bump to 2.138.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.138.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index ebead6e9926f..424ea804c100 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.136.0.tar.gz 11443821 BLAKE2B ee313274ec25e1262ad54b800cf524e58400886876d9133b7c6e1d9668e81bce7b73f96511679bcc2a0f565ca9b89c7d6bc7087213e53575542c5e0b5e566ff9 SHA512 e5e8302c71953f0971d3b3159d7689cd76520efa4cee9ca541e78a5fcb14387506963cb20da06ac5760af814ece5ded0bc3942381aa9e96fd6c620eb8933a6ed
DIST google_api_python_client-2.137.0.tar.gz 11477114 BLAKE2B e0d7e64bfdd86bd882c8762b8d78fcd390152e569ca32df16fcbe91290508565086e4ca7e958d8d48ecaa6d5d23a0b1188b85f6a53004af54139977602c4f72c SHA512 442c08033fb12dbdcab3e45b911a9d43d93a4841369cd14344c9201a40b453d88ce602c3f45d965713ca826bec1f3e333f9425008d1cf1f59b6441283eb09807
+DIST google_api_python_client-2.138.0.tar.gz 11595036 BLAKE2B 554abf4e58264d60a5a09174b7199f31ac6cf31bd024add66ff73a71992e9da077c8046abfd8d9400d1b17fa0ccd27ca484ae62dca8b6900bbad42e2a26af9ee SHA512 f9e7501a289e96aebe8db78e32dc30771a860af34808d1bc6d6192c4511ecbbf871cbbf8cdf50daeeb865908a86236400d651e159d913b415b1f2fdf8eb045ab
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.138.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.138.0.ebuild
new file mode 100644
index 000000000000..58a0eb467bad
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.138.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}