summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-20 22:52:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-20 22:52:14 -0500
commit4b23c19e6010a33a87af96adfda22041af2e3d8b (patch)
treef7cb2d596dde8b9d9de45620c5968c5c7f074f8c /dev-python/glance_store
parentsys-devel/{gcc,gcc-apple,kgcc64}: update USE=multislot description (diff)
downloadgentoo-4b23c19e6010a33a87af96adfda22041af2e3d8b.tar.gz
gentoo-4b23c19e6010a33a87af96adfda22041af2e3d8b.tar.bz2
gentoo-4b23c19e6010a33a87af96adfda22041af2e3d8b.zip
dev-python/glance_store: bup liberty
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest1
-rw-r--r--dev-python/glance_store/glance_store-0.9.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index 4b3734ebaffe..397625eab3ea 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -3,3 +3,4 @@ DIST glance_store-0.4.0.tar.gz 103982 SHA256 cd15e9f9a08dc8d3eeaa452682c8e53423f
DIST glance_store-0.5.0.tar.gz 106922 SHA256 bb088cea0f83d3335191174b3fbdd5f5b2a39ae4f6e0739b9159e883658657db SHA512 e9f036c9f19ca2f3b8ba82a288a6402c91d849409f4594c61c59c14c8575b5827cf8e072c4772f5ef610fd186037b2d3c5cbc5fb032ca02c025e58a6a59a2dfa WHIRLPOOL 1943b6a26e96a9043b99d6d9b8c9af78468d05f825812250f7c7c396977d4e76d9370fe0c3fd2043d67d519c53c5e11c7541ae4f0389179b61e083f059cc5aea
DIST glance_store-0.6.0.tar.gz 106047 SHA256 249c99818f7ebd1b3aea6c96a66e4e17351a1d9befaef885dada0483be6ee818 SHA512 065c3d68b67ce38a82f8eba29630f368bc723f2c6a34ed1c7adb2ab90f5d24c1b7f32a55c200e5b45167b26bd4d3dae5194484e9de17286cdd91685898276388 WHIRLPOOL c4553654288dc2f3f823a7fbde4ff4c2f1c97b704ff3f55069153819da64ffeb06380975a80db08a1dd33cbbc25418e233b1eadc2aee5569d125223efde69e4c
DIST glance_store-0.9.1.tar.gz 110360 SHA256 29eb70a36b18cd9dce1f9f58b8a3c7dd69626b13a8e5a46c8f807e9d301d5f99 SHA512 60880a25cb4918ed8b4a9ee81bf6bc4b5732332dad48807b687c26917b4271d47f65dbbc3b1879db48f17efa4afe605d151a23aec7f3525621d61ee4a9751146 WHIRLPOOL c34e3aee26b7fe70ce68310a3a190f18670d266ba9942eccf3a87238dbe85063fb59935e4c9cee58d1fd88c22a918b76773994b33142fe6e0bf9e61e2fd4affc
+DIST glance_store-0.9.2.tar.gz 111529 SHA256 01e5225ff4147b54a46bb7b66a508cdb9702fc22a86f79a3b36ef067e87e7e4d SHA512 059fd3589085e98855b0baaf42f33814c921ea1eea84663c19fae076a28ba5286a3869b9e0087040df100aa72156c416b09ddd2fe343f9dbc7726814b0f4361e WHIRLPOOL 962eca6aeaf3c68b8dd5b26805fc2a0a46a00b114daaadca8798eb35ea918a3c87283203179cd4a6d46c903e32e618251715b19fd813a7fad662e1871e86fdbd
diff --git a/dev-python/glance_store/glance_store-0.9.2.ebuild b/dev-python/glance_store/glance_store-0.9.2.ebuild
new file mode 100644
index 000000000000..a9c32eac3d02
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.9.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+cinder +swift"
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-utils-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
+ dev-python/enum34[$(python_gen_usedep 'python2*')]
+ >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] )
+ swift? (
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}]
+ )
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/ordereddict/d' requirements.txt
+ distutils-r1_python_prepare_all
+}