summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/gitdb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/Manifest2
-rw-r--r--dev-python/gitdb/gitdb-0.6.3.ebuild30
-rw-r--r--dev-python/gitdb/gitdb-0.6.4.ebuild30
-rw-r--r--dev-python/gitdb/metadata.xml9
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/gitdb/Manifest b/dev-python/gitdb/Manifest
new file mode 100644
index 000000000000..c45197580912
--- /dev/null
+++ b/dev-python/gitdb/Manifest
@@ -0,0 +1,2 @@
+DIST gitdb-0.6.3.tar.gz 400070 SHA256 2735e2e5d914c77a6a5d80566670ba18b32022e859ecfc9b2e7ae8f11fa1960e SHA512 e7a08eb0f1b7bf6c8e23787580e4efbdc645b078fbf7ad130ebe9f3d29722d642f70c36fbb676a360ed787885dc05f4a574b9ca59a1c1abd38c38bc3b1b1270c WHIRLPOOL b447e29c645519cfaa11aa010799f43f6ca588d2f1c58041f473717f9149fa472a23d5178b141b9cb32485eeef3112787f9cd330aca037b3dce996cc195a9858
+DIST gitdb-0.6.4.tar.gz 400506 SHA256 a3ebbc27be035a2e874ed904df516e35f4a29a778a764385de09de9e0f139658 SHA512 2314ae70ec26c46c559cc69a1300ead8cd65a0a22425a3bb36b04edb73bd5e2628cbdcd8e515830c74b21af2badea662c915a727d9a46ed2f92f169eb71bdf62 WHIRLPOOL df7425efd5f2c6a704b3545723ce8e27fdca09c435f52685dd4dcca7eb3eb3da8d89fbe88e2d9dfee7984b029b9ea741b32a6afcdbccb5bcbd7b04ce59f6d552
diff --git a/dev-python/gitdb/gitdb-0.6.3.ebuild b/dev-python/gitdb/gitdb-0.6.3.ebuild
new file mode 100644
index 000000000000..2af816f66c51
--- /dev/null
+++ b/dev-python/gitdb/gitdb-0.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ http://pypi.python.org/pypi/gitdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git
+ >=dev-python/smmap-0.8.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+# Testsuite appears to require files from a git repo
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
diff --git a/dev-python/gitdb/gitdb-0.6.4.ebuild b/dev-python/gitdb/gitdb-0.6.4.ebuild
new file mode 100644
index 000000000000..e44f9197a0bb
--- /dev/null
+++ b/dev-python/gitdb/gitdb-0.6.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ http://pypi.python.org/pypi/gitdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git
+ >=dev-python/smmap-0.8.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+# Testsuite appears to require files from a git repo
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
diff --git a/dev-python/gitdb/metadata.xml b/dev-python/gitdb/metadata.xml
new file mode 100644
index 000000000000..9aaab6399701
--- /dev/null
+++ b/dev-python/gitdb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">gitdb</remote-id>
+ <remote-id type="github">gitpython-developers/gitdb</remote-id>
+ </upstream>
+</pkgmetadata>