summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 08:25:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 08:55:23 +0200
commit9c02b908d2e04c7b4f789a00efa1c4fde5fd60fd (patch)
tree6d24ad8f19b76e2ef8b99eb5b214074612373cbf /dev-python/fsspec
parentdev-python/jc: Bump to 1.23.5 (diff)
downloadgentoo-9c02b908d2e04c7b4f789a00efa1c4fde5fd60fd.tar.gz
gentoo-9c02b908d2e04c7b4f789a00efa1c4fde5fd60fd.tar.bz2
gentoo-9c02b908d2e04c7b4f789a00efa1c4fde5fd60fd.zip
dev-python/fsspec: Bump to 2023.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2023.10.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 6f6c20cff8b3..b2f646f387e6 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
+DIST filesystem_spec-2023.10.0.gh.tar.gz 404845 BLAKE2B 6c8cf801664c9fc848cb55660db1725c90facf534d58e49f604b2051d1b6a78d13d8f083282071beb7ab3dcb8d75f6d52fe24ce744c5cf1808b4ae3cb673998d SHA512 cb449052208516930c73dbe1de7c495d252677a3d3d85267836224d79c1b8cf9449ebdba8287f6f6206d5a8e631a99cd81c2fb62b82288a626a202876a45139c
DIST filesystem_spec-2023.9.2.gh.tar.gz 400298 BLAKE2B ef7c7c2eac91b190277331aac30b2b03605d3e2758536f6f0d3b894b5e236aa77f3c94a05105180ba44aa438204ef636dcfae8c35c307b40f6e7b2ce8a6e1e2c SHA512 bc61ec65af387f9f11d8f48f57fc50fed657ff6f078f619dd2c6bef20e50576533e34da8452ec13af1e30be336674f2d38032b027c8e9354144b7ed7023b50fe
diff --git a/dev-python/fsspec/fsspec-2023.10.0.ebuild b/dev-python/fsspec/fsspec-2023.10.0.ebuild
new file mode 100644
index 000000000000..1cdf466d85da
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2023.10.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+ # requires s3fs
+ fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
+ fsspec/tests/test_core.py::test_mismatch
+ # requires pyarrow, fastparquet
+ fsspec/implementations/tests/test_reference.py::test_df_single
+ fsspec/implementations/tests/test_reference.py::test_df_multi
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+)