summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-01 09:52:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-01 09:52:52 +0300
commit9537fc033934eacee8a4e5f86f91492cb689582c (patch)
tree93b16742242b9c7e90cbe4103c3c7012cbb84e37 /dev-python/fsspec
parentdev-libs/nss: add 3.77 (diff)
downloadgentoo-9537fc033934eacee8a4e5f86f91492cb689582c.tar.gz
gentoo-9537fc033934eacee8a4e5f86f91492cb689582c.tar.bz2
gentoo-9537fc033934eacee8a4e5f86f91492cb689582c.zip
dev-python/fsspec: add 2022.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2022.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 3d6c3e1691f0..974d65100566 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2022.02.0.tar.gz 329625 BLAKE2B c3d3815ece4cc3a0713d2ee6fd70c55a3236c926dd389dd55866bd6a11c63e6225cd4415dd310876b8e271bf82534826452a3327693f94bd8c8b5b7aa7893222 SHA512 6cc26cb61c75fea4ab7af37190a623a4fa07d85ff540accc4d85e8ebab5f6bcc78099e85a6196f93c9d7f4e0e0380395ad2625b485858fb8db40f7c2682f8c4d
+DIST filesystem_spec-2022.3.0.tar.gz 331768 BLAKE2B 8f4e75f839419f7445a9291e3b67914338b0371742f1d3a556962b6e5abb31379cfeba52e0101f7660fd69569dabb49190820323b7e067a0c33c2184422ba067 SHA512 7c793b506e93f727bc4533a778f6108f82c9ab9274a8d259ecf483e0acbbfc97e3c8b07735f772f996867053d7e1f9c22687865f4f64cae6eb4fb511de2e9220
diff --git a/dev-python/fsspec/fsspec-2022.3.0.ebuild b/dev-python/fsspec/fsspec-2022.3.0.ebuild
new file mode 100644
index 000000000000..ede5cd75981b
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2022.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+)