summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-10 05:34:17 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-10 06:40:36 +0200
commit63afcb72e92de19f69495495738be4e1b7b3cd70 (patch)
treec0f1149fc956d1f125c35f4a0f449a89ca84a181 /dev-python/fsspec
parentdev-python/mistune: Bump to 3.0.1 (diff)
downloadgentoo-63afcb72e92de19f69495495738be4e1b7b3cd70.tar.gz
gentoo-63afcb72e92de19f69495495738be4e1b7b3cd70.tar.bz2
gentoo-63afcb72e92de19f69495495738be4e1b7b3cd70.zip
dev-python/fsspec: Bump to 2023.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2023.6.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index f6c56e5d6418..fb349281a3bd 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2023.5.0.gh.tar.gz 362014 BLAKE2B 9a037ebba1d02c3b3fcb2ba37b2074bef3575bdafbfb3aa1d4ec5ffe5dd109e1f7bb05de22430f077ee9d05216762b973687ae7175669600d063ab553bcd7f0b SHA512 6f8e574ab234ea6184ab908d4bd475b4e734ce56e49d0efc4d0b2403e67e84448545e82fe33be408d51dffb56f100844e03c283760d921287d530176159ecf9d
+DIST filesystem_spec-2023.6.0.gh.tar.gz 386708 BLAKE2B e47825893073d969eff8c7936068c26bed270d3b65fb4407f64b5032ce8e71b7794ae6b3ae16fb08ec3e1e2f830b2fce7fa238fd8189354e8a16c618e2af7398 SHA512 ede711d22dede2deee1b36f2ca591bc96a8f1b66d6cb16cc2ad6e1776ea441a1c73382b7622262872a3f5fff92b15ba6bdabaca80fd0ed898b7ddcac02792cf7
diff --git a/dev-python/fsspec/fsspec-2023.6.0.ebuild b/dev-python/fsspec/fsspec-2023.6.0.ebuild
new file mode 100644
index 000000000000..24baae856eb8
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2023.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+ # requires s3fs
+ fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
+ fsspec/tests/test_core.py::test_mismatch
+ # requires pyarrow, fastparquet
+ fsspec/implementations/tests/test_reference.py::test_df_single
+ fsspec/implementations/tests/test_reference.py::test_df_multi
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+)