summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-04 07:20:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-04 07:26:52 +0200
commit4fe5b85dc2b7b565a84559bb046692324165efd3 (patch)
treed47fc7a523edcb0822f7116d2006d485316dbde3 /dev-python/fsspec
parentdev-python/uv: Bump to 0.2.6 (diff)
downloadgentoo-4fe5b85dc2b7b565a84559bb046692324165efd3.tar.gz
gentoo-4fe5b85dc2b7b565a84559bb046692324165efd3.tar.bz2
gentoo-4fe5b85dc2b7b565a84559bb046692324165efd3.zip
dev-python/fsspec: Bump to 2024.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2024.6.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index d267a3a17975..bedc23d1766a 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
+DIST filesystem_spec-2024.6.0.gh.tar.gz 409087 BLAKE2B 2ef06faec98173f0a13be365f1f9debca11e4587557b50a0b546b49c014782f4ab70c008a0a12158ce156dd5052b06fe67e9135f414f0c8a5829bf15b4b96f07 SHA512 97ecc5622787dc96d4cc05e7474da214405ae34d1eeee125752133258ea8c0ed9278d8d868544102a271431b01b797adea3834b3b2441e09c85dea01b56af066
DIST fsspec-2024.5.0.tar.gz 400066 BLAKE2B 4f497fa8efe4897958414e2739c06fed54ecd67babb7cbdfeb0c1b595547213aed1fb15f97dbd2f7f61a84fef7f3a96f36bb1ab5a2f4ca94251e7dccd64afe22 SHA512 b8430350c56ecaeca9496b6de7910d7f4423e17beb4250dcb440d9af6ab34ed83e2e9304b474d4b5611a9ee0941c34eba5c62d5a1f7d0cc1384d976ae3266e7f
diff --git a/dev-python/fsspec/fsspec-2024.6.0.ebuild b/dev-python/fsspec/fsspec-2024.6.0.ebuild
new file mode 100644
index 000000000000..b95c492ab999
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+# upstream removed tests in 2024.6.0
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}