summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-05 13:59:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-05 15:34:52 +0100
commit4b9d32a2f6b98ddb29622e82b16938bc3882242e (patch)
treeb7e8aa10251495f74673fbcd8368a6b770c30d1c /dev-python/fsspec
parentwww-apps/readarr: drop 0.3.17.2409 (diff)
downloadgentoo-4b9d32a2f6b98ddb29622e82b16938bc3882242e.tar.gz
gentoo-4b9d32a2f6b98ddb29622e82b16938bc3882242e.tar.bz2
gentoo-4b9d32a2f6b98ddb29622e82b16938bc3882242e.zip
dev-python/fsspec: Fix test regressions
Closes: https://bugs.gentoo.org/923045 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/fsspec-2023.12.2.ebuild41
-rw-r--r--dev-python/fsspec/fsspec-2024.2.0.ebuild39
2 files changed, 45 insertions, 35 deletions
diff --git a/dev-python/fsspec/fsspec-2023.12.2.ebuild b/dev-python/fsspec/fsspec-2023.12.2.ebuild
index 397fa9af6b6b..5838f67c5f3f 100644
--- a/dev-python/fsspec/fsspec-2023.12.2.ebuild
+++ b/dev-python/fsspec/fsspec-2023.12.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -45,21 +45,26 @@ src_test() {
distutils-r1_src_test
}
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+ # requires s3fs
+ fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
+ fsspec/tests/test_core.py::test_mismatch
+ # requires pyarrow, fastparquet
+ fsspec/implementations/tests/test_reference.py::test_df_single
+ fsspec/implementations/tests/test_reference.py::test_df_multi
+ )
+
+ local EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+ )
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}
diff --git a/dev-python/fsspec/fsspec-2024.2.0.ebuild b/dev-python/fsspec/fsspec-2024.2.0.ebuild
index b698530b6789..68c6f4a4b1af 100644
--- a/dev-python/fsspec/fsspec-2024.2.0.ebuild
+++ b/dev-python/fsspec/fsspec-2024.2.0.ebuild
@@ -45,21 +45,26 @@ src_test() {
distutils-r1_src_test
}
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+ # requires s3fs
+ fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
+ fsspec/tests/test_core.py::test_mismatch
+ # requires pyarrow, fastparquet
+ fsspec/implementations/tests/test_reference.py::test_df_single
+ fsspec/implementations/tests/test_reference.py::test_df_multi
+ )
+
+ local EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+ )
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}