summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-06 17:04:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-06 17:07:44 +0200
commit1bee2529de8528d79bf889ed633e8836c8a08c01 (patch)
treede62d18736cf31e36d14bc7ce472d418278791db /dev-python/fsspec
parentdev-python/aiohttp-socks: Remove old (diff)
downloadgentoo-1bee2529de8528d79bf889ed633e8836c8a08c01.tar.gz
gentoo-1bee2529de8528d79bf889ed633e8836c8a08c01.tar.bz2
gentoo-1bee2529de8528d79bf889ed633e8836c8a08c01.zip
dev-python/fsspec: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest3
-rw-r--r--dev-python/fsspec/fsspec-2023.6.0.ebuild64
-rw-r--r--dev-python/fsspec/fsspec-2023.9.0.ebuild64
-rw-r--r--dev-python/fsspec/fsspec-2023.9.1.ebuild64
4 files changed, 0 insertions, 195 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 4d51e796e883..6f6c20cff8b3 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,4 +1 @@
-DIST filesystem_spec-2023.6.0.gh.tar.gz 386708 BLAKE2B e47825893073d969eff8c7936068c26bed270d3b65fb4407f64b5032ce8e71b7794ae6b3ae16fb08ec3e1e2f830b2fce7fa238fd8189354e8a16c618e2af7398 SHA512 ede711d22dede2deee1b36f2ca591bc96a8f1b66d6cb16cc2ad6e1776ea441a1c73382b7622262872a3f5fff92b15ba6bdabaca80fd0ed898b7ddcac02792cf7
-DIST filesystem_spec-2023.9.0.gh.tar.gz 399288 BLAKE2B 47317bf4c50dc2e4dd541100d67989c16fcd9a0d21f2b871386cf2c379389487f51af5b81420b9b455ec083e250e2bb1b0da8243b25512f6ad227b1c16357741 SHA512 4a19f24fa3e41da0aa6f7b22b1720ee093260c5b3ff9547f678ea00887f8d12cb048dad6b2a27ea3743d3cca7837a19b061a63c5d96e10227139ebdefcaec3d0
-DIST filesystem_spec-2023.9.1.gh.tar.gz 400280 BLAKE2B e964891cd2af1d3789e39e59481316ecc0e16046e262e5c8783d734ea97ee8d39ee94514af4cfd62a4f78c03973e83c630232dfda19ff045670874229704ef45 SHA512 b7f7df1c73fb6c0ce4537d99e04e8775bb3dde37a1821976d2b44015e0b3d1a85633eef73822c74871ede1032672b2b021f6944b7ecca12f9d6baed2f6c20d6a
DIST filesystem_spec-2023.9.2.gh.tar.gz 400298 BLAKE2B ef7c7c2eac91b190277331aac30b2b03605d3e2758536f6f0d3b894b5e236aa77f3c94a05105180ba44aa438204ef636dcfae8c35c307b40f6e7b2ce8a6e1e2c SHA512 bc61ec65af387f9f11d8f48f57fc50fed657ff6f078f619dd2c6bef20e50576533e34da8452ec13af1e30be336674f2d38032b027c8e9354144b7ed7023b50fe
diff --git a/dev-python/fsspec/fsspec-2023.6.0.ebuild b/dev-python/fsspec/fsspec-2023.6.0.ebuild
deleted file mode 100644
index e4b3b7ef69a2..000000000000
--- a/dev-python/fsspec/fsspec-2023.6.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="
- https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/
-"
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
-)
-
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)
diff --git a/dev-python/fsspec/fsspec-2023.9.0.ebuild b/dev-python/fsspec/fsspec-2023.9.0.ebuild
deleted file mode 100644
index 5e5f5057b1a9..000000000000
--- a/dev-python/fsspec/fsspec-2023.9.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="
- https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/
-"
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
-)
-
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)
diff --git a/dev-python/fsspec/fsspec-2023.9.1.ebuild b/dev-python/fsspec/fsspec-2023.9.1.ebuild
deleted file mode 100644
index 5e5f5057b1a9..000000000000
--- a/dev-python/fsspec/fsspec-2023.9.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="
- https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/
-"
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
-)
-
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)