summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 08:00:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 08:08:34 +0200
commit11ac328537b138bbd5b491f88ae83955f2f2a053 (patch)
tree9b883387fbf640e76a8a76bed4546389aae16e27 /dev-python/flatdict
parentdev-python/pywlroots: Bump to 0.16.4 (diff)
downloadgentoo-11ac328537b138bbd5b491f88ae83955f2f2a053.tar.gz
gentoo-11ac328537b138bbd5b491f88ae83955f2f2a053.tar.bz2
gentoo-11ac328537b138bbd5b491f88ae83955f2f2a053.zip
dev-python/flatdict: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flatdict')
-rw-r--r--dev-python/flatdict/Manifest1
-rw-r--r--dev-python/flatdict/flatdict-4.0.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/flatdict/Manifest b/dev-python/flatdict/Manifest
index b2534e7d6697..a3be2445fc3f 100644
--- a/dev-python/flatdict/Manifest
+++ b/dev-python/flatdict/Manifest
@@ -1 +1,2 @@
DIST flatdict-4.0.0.gh.tar.gz 11790 BLAKE2B be8234cc7e4378a2ab54e1676e947a664bde8c62c881ff9ba074e36f21d07bc726311f39acc2c1531ca689b68e398467222b616b2334cd44edc9972345ffde68 SHA512 e1203fb772594ee4b19fb137dbef0c1319ffacda28ffc53532707a03e5c1446d5449114588ef832fa46162a3d710579ed7405943ced65e08fd16bd956ef17ca4
+DIST flatdict-4.0.1.gh.tar.gz 11923 BLAKE2B 102ebc6220d75219b91ed7494485fa7d1447801d8276fd5e305f838f6b339b72c44151c751a53c32a5ea5b1d4876d9312af229bb8972401a2f86d6488d3f8b4f SHA512 925ad8a53a4848875ff5c0df2c006ea09ff3795861cd0b8d7c26d22511d46d4ad28dee28b3e9e8f896b45c8a1b2c51cc24bce099c38c0b4d2f49174baab4de23
diff --git a/dev-python/flatdict/flatdict-4.0.1.ebuild b/dev-python/flatdict/flatdict-4.0.1.ebuild
new file mode 100644
index 000000000000..5a3a5555d40a
--- /dev/null
+++ b/dev-python/flatdict/flatdict-4.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for interacting with nested dicts"
+HOMEPAGE="
+ https://github.com/gmr/flatdict/
+ https://pypi.org/project/flatdict/
+"
+SRC_URI="
+ https://github.com/gmr/flatdict/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest