summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-04 13:03:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-04 13:03:14 +0200
commitd9110418fa19e91b95fc35a6b4c849116043d141 (patch)
treef8cc53dec59a29799d9e37e250820c2dceca96e8 /dev-python/flask
parentdev-python/flask-babel: Remove old (diff)
downloadgentoo-d9110418fa19e91b95fc35a6b4c849116043d141.tar.gz
gentoo-d9110418fa19e91b95fc35a6b4c849116043d141.tar.bz2
gentoo-d9110418fa19e91b95fc35a6b4c849116043d141.zip
dev-python/flask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-1.1.1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 1fa12878fd71..011f7d068901 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,4 +1,3 @@
DIST Flask-0.12.2.tar.gz 548510 BLAKE2B bd92d0e7e6ff36d371ffd958708517d16e41d1475af9153bf3d5234c33aa5c0ab415cbd254b711731cf8cffddac94b475f62d9fff2f9fe756b0fa30bb36d4343 SHA512 c00bb807e8fbc943e23a3721acf5b04320e7a58d658bca46bdf83a345b4c4d5729accae338505e134f01bc908adec9555fd94e8c87ef6f0367e6037215c06319
DIST Flask-1.0.4.tar.gz 615497 BLAKE2B 4141de3754a8ce42c6978a72da80c991d13415a19946180f5fd8f08a1827209be605ec10283b78841bee94c5a2036b8e6083187a3e68c188fde93cb702a6d645 SHA512 2ed45ebdef80fe354a0a221f991560e17c442550f667fb76dd9c9631428fe8b6686127504f4ee81fcc6748f99cd376bed7a1ff4e0a9ae913cd70c9f5f4ac1c61
-DIST Flask-1.1.1.tar.gz 625458 BLAKE2B aea56848dd1f8bb2d96059adf069f8d19c55395e5dd0d98bf4e89c7d1b54241f1f476cbf7fdb91a2390cb5438a3bd7a5bdb58383f2a196b042e90f272cb39e53 SHA512 d4e6304bdb2e20deda5b9800dc9ebeabf0442528d6cef2d15416129c151b25ab32c41460939f64fb72b15ead8d4e9bcea5694039323d080d279bfba2f6266178
DIST Flask-1.1.2.tar.gz 637516 BLAKE2B 90dffbb8faa48489d1c71ff2a064d41e97d2103c07532fd5b252dbe0b32e4babb815e31f0ceae201a66cead645b68149d13d4bb39a0df1b27b4002e613920493 SHA512 9feb6a9a8f34fadbea508d465f73c24b1d81b3f66243804dc3904d198c2fd78e2e1bef94df6a4940a7eec6b9b54abea06557a87de8b27b0a9497d18b3e071384
diff --git a/dev-python/flask/flask-1.1.1.ebuild b/dev-python/flask/flask-1.1.1.ebuild
deleted file mode 100644
index 49061bff4889..000000000000
--- a/dev-python/flask/flask-1.1.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/click[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.15[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- # taken from upstream git, will be in next release
- "${FILESDIR}/flask-1.1.1-py38.patch"
-)
-
-distutils_enable_sphinx docs
-
-python_test() {
- PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- pytest -vv -p no:httpbin || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}